I want to start XAMPP Apache server but it terminal it says that another web server daemon is already running. So I want to find out how to turn off it or so.

When I go to localhost I get following message:

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.

When I go to localhost/index.php I get this message:

Not Found

The requested URL /index.php was not found on this server.

Apache/2.2.14 (Ubuntu) Server at localhost Port 80

But it worked when I was starting XAMPP Apache and going to localhost earlier, it would open my index.php page and now I can't start it.

I'm not sure if that webserver is Apache, but I'm just telling what happens when I go to localhost

So what I should do? I am using Ubuntu 10.04


Well XAMPP is an all in one package which brings its own apache with it. But Ubuntu has all these packages in its main repository, so I would suggest you opt to use Ubuntu packages to setup your server (There are How-To's online, e.g. https://help.ubuntu.com/community/ApacheMySQLPHP)

Another option is to remove the Ubuntu provided Apache:

sudo aptitude purge apache2

You can then try to start XAMPP again and connect to your local webserver.

  • 1
    @Thomas, I think Ubuntu 10.04 doesnt use upstart scripts for apache. Try sudo /etc/init.d/apache2 stop instead – falstaff Sep 8 '11 at 12:51
  • But one week ago everything was fine, and I was just starting XAMPP and it worked, so it means something happened, maybe I installed something or so – Templar Sep 8 '11 at 12:51
  • The command sudo aptitude purge apache2 should remove those packages (sorry, I forgot the two at the end) – falstaff Sep 8 '11 at 12:53
  • sudo service apache2 stop worked – Templar Sep 8 '11 at 12:54
  • This stopped your apache2 service. You will have the problem again when you reboot your system next time. You can permanently remove Ubuntu's apache using sudo aptitude purge apache2... – falstaff Sep 8 '11 at 13:00
sudo service apache stop

You might try to remove the apache package.

  • I get apache: unrecognized service maybe it's not apache I don't know – Templar Sep 8 '11 at 12:47
  • I is apache - see the error message you get when you try to get localhost/index.php. The servie name could be apache2 - take a look at /etc/init.d/ to find out. – Thomas Sep 8 '11 at 12:49
  • yeah sudo service apache2 stop worked and now I started XAMPP and everything's fine – Templar Sep 8 '11 at 12:55
sudo /etc/init.d/apache2 stop
sudo /opt/lampp/lampp restart

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.