I downloaded the latest version of the VMWare player (v 7.1.0) from here. Installed the bundle, and the installation went through fine.

Post-installation, when I tried to launch VMWare Player, but got this prompt: enter image description here

Proceeding lead to these error screens:
enter image description here enter image description here

I am aware that this is an old problem, mentioned, for example, here, here and here. They all seem to point to the same solution here, which has worked for some in the past.

I tried to follow the instructions there, but firstly, the patch to the file vmnet-only/filter.c did not take, so I manually updated the file to contain:

#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 13, 0)
 transmit = (hooknum == VMW_NF_INET_POST_ROUTING);
#else
 transmit = (ops->hooknum == VMW_NF_INET_POST_ROUTING);
#endif

I then repackaged and tried to start VMWare Player, but it still would not start, with the same error as before. Here are the contents of the log file that it points me to.

2015-04-05T13:39:03.888+05:30| vthread-4| I120: Log for VMware Workstation pid=7861 version=11.1.0 build=build-2496824 option=Release
2015-04-05T13:39:03.888+05:30| vthread-4| I120: The process is 64-bit.
2015-04-05T13:39:03.888+05:30| vthread-4| I120: Host codepage=UTF-8 encoding=UTF-8
2015-04-05T13:39:03.888+05:30| vthread-4| I120: Host is Linux 3.19.0-10-generic Ubuntu Vivid Vervet (development branch)
2015-04-05T13:39:03.888+05:30| vthread-4| I120: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2015-04-05T13:39:03.888+05:30| vthread-4| I120: Msg_Reset:
2015-04-05T13:39:03.888+05:30| vthread-4| I120: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2015-04-05T13:39:03.888+05:30| vthread-4| I120: ----------------------------------------
2015-04-05T13:39:03.888+05:30| vthread-4| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
2015-04-05T13:39:03.888+05:30| vthread-4| I120: DictionaryLoad: Cannot open file "/root/.vmware/config": No such file or directory.
2015-04-05T13:39:03.888+05:30| vthread-4| I120: Msg_Reset:
2015-04-05T13:39:03.888+05:30| vthread-4| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/config": No such file or directory.
2015-04-05T13:39:03.888+05:30| vthread-4| I120: ----------------------------------------
2015-04-05T13:39:03.888+05:30| vthread-4| I120: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
2015-04-05T13:39:03.888+05:30| vthread-4| I120: PREF Unable to check permissions for preferences file.
2015-04-05T13:39:03.888+05:30| vthread-4| I120: DictionaryLoad: Cannot open file "/root/.vmware/preferences": No such file or directory.
2015-04-05T13:39:03.888+05:30| vthread-4| I120: Msg_Reset:
2015-04-05T13:39:03.888+05:30| vthread-4| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/preferences": No such file or directory.
2015-04-05T13:39:03.888+05:30| vthread-4| I120: ----------------------------------------
2015-04-05T13:39:03.888+05:30| vthread-4| I120: PREF Failed to load user preferences.
2015-04-05T13:39:03.921+05:30| vthread-4| W110: Logging to /tmp/vmware-root/vmware-7861.log
2015-04-05T13:39:03.929+05:30| vthread-4| I120: Obtaining info using the running kernel.
2015-04-05T13:39:03.930+05:30| vthread-4| I120: Created new pathsHash.
2015-04-05T13:39:03.930+05:30| vthread-4| I120: Setting header path for 3.19.0-10-generic to "/lib/modules/3.19.0-10-generic/build/include".
2015-04-05T13:39:03.930+05:30| vthread-4| I120: Validating path "/lib/modules/3.19.0-10-generic/build/include" for kernel release "3.19.0-10-generic".
2015-04-05T13:39:03.930+05:30| vthread-4| I120: Failed to find /lib/modules/3.19.0-10-generic/build/include/linux/version.h
2015-04-05T13:39:03.930+05:30| vthread-4| I120: /lib/modules/3.19.0-10-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-04-05T13:39:03.930+05:30| vthread-4| I120: using /usr/bin/gcc-4.9 for preprocess check
2015-04-05T13:39:03.934+05:30| vthread-4| I120: Preprocessed UTS_RELEASE, got value "3.19.0-10-generic".
2015-04-05T13:39:03.934+05:30| vthread-4| I120: The header path "/lib/modules/3.19.0-10-generic/build/include" for the kernel "3.19.0-10-generic" is valid.  Whoohoo!
2015-04-05T13:39:04.037+05:30| vthread-4| I120: found symbol version file /lib/modules/3.19.0-10-generic/build/Module.symvers
2015-04-05T13:39:04.037+05:30| vthread-4| I120: Reading symbol versions from /lib/modules/3.19.0-10-generic/build/Module.symvers.
2015-04-05T13:39:04.052+05:30| vthread-4| I120: Read 18765 symbol versions
2015-04-05T13:39:04.052+05:30| vthread-4| I120: Reading in info for the vmmon module.
2015-04-05T13:39:04.052+05:30| vthread-4| I120: Reading in info for the vmnet module.
2015-04-05T13:39:04.052+05:30| vthread-4| I120: Reading in info for the vmblock module.
2015-04-05T13:39:04.052+05:30| vthread-4| I120: Reading in info for the vmci module.
2015-04-05T13:39:04.052+05:30| vthread-4| I120: Reading in info for the vsock module.
2015-04-05T13:39:04.052+05:30| vthread-4| I120: Setting vsock to depend on vmci.
2015-04-05T13:39:04.052+05:30| vthread-4| I120: Invoking modinfo on "vmmon".
2015-04-05T13:39:04.054+05:30| vthread-4| I120: "/sbin/modinfo" exited with status 0.
2015-04-05T13:39:04.054+05:30| vthread-4| I120: Invoking modinfo on "vmnet".
2015-04-05T13:39:04.055+05:30| vthread-4| I120: "/sbin/modinfo" exited with status 256.
2015-04-05T13:39:04.055+05:30| vthread-4| I120: Invoking modinfo on "vmblock".
2015-04-05T13:39:04.056+05:30| vthread-4| I120: "/sbin/modinfo" exited with status 256.
2015-04-05T13:39:04.056+05:30| vthread-4| I120: Invoking modinfo on "vmci".
2015-04-05T13:39:04.057+05:30| vthread-4| I120: "/sbin/modinfo" exited with status 256.
2015-04-05T13:39:04.057+05:30| vthread-4| I120: Invoking modinfo on "vsock".
2015-04-05T13:39:04.058+05:30| vthread-4| I120: "/sbin/modinfo" exited with status 0.
2015-04-05T13:39:04.067+05:30| vthread-4| I120: to be installed: vmnet status: 0
2015-04-05T13:39:04.078+05:30| vthread-4| I120: Obtaining info using the running kernel.
2015-04-05T13:39:04.078+05:30| vthread-4| I120: Setting header path for 3.19.0-10-generic to "/lib/modules/3.19.0-10-generic/build/include".
2015-04-05T13:39:04.078+05:30| vthread-4| I120: Validating path "/lib/modules/3.19.0-10-generic/build/include" for kernel release "3.19.0-10-generic".
2015-04-05T13:39:04.078+05:30| vthread-4| I120: Failed to find /lib/modules/3.19.0-10-generic/build/include/linux/version.h
2015-04-05T13:39:04.078+05:30| vthread-4| I120: /lib/modules/3.19.0-10-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-04-05T13:39:04.078+05:30| vthread-4| I120: using /usr/bin/gcc-4.9 for preprocess check
2015-04-05T13:39:04.082+05:30| vthread-4| I120: Preprocessed UTS_RELEASE, got value "3.19.0-10-generic".
2015-04-05T13:39:04.082+05:30| vthread-4| I120: The header path "/lib/modules/3.19.0-10-generic/build/include" for the kernel "3.19.0-10-generic" is valid.  Whoohoo!
2015-04-05T13:39:04.185+05:30| vthread-4| I120: found symbol version file /lib/modules/3.19.0-10-generic/build/Module.symvers
2015-04-05T13:39:04.185+05:30| vthread-4| I120: Reading symbol versions from /lib/modules/3.19.0-10-generic/build/Module.symvers.
2015-04-05T13:39:04.200+05:30| vthread-4| I120: Read 18765 symbol versions
2015-04-05T13:39:04.201+05:30| vthread-4| I120: Kernel header path retrieved from FileEntry: /lib/modules/3.19.0-10-generic/build/include
2015-04-05T13:39:04.201+05:30| vthread-4| I120: Update kernel header path to /lib/modules/3.19.0-10-generic/build/include
2015-04-05T13:39:04.201+05:30| vthread-4| I120: Validating path "/lib/modules/3.19.0-10-generic/build/include" for kernel release "3.19.0-10-generic".
2015-04-05T13:39:04.201+05:30| vthread-4| I120: Failed to find /lib/modules/3.19.0-10-generic/build/include/linux/version.h
2015-04-05T13:39:04.201+05:30| vthread-4| I120: /lib/modules/3.19.0-10-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-04-05T13:39:04.201+05:30| vthread-4| I120: using /usr/bin/gcc-4.9 for preprocess check
2015-04-05T13:39:04.205+05:30| vthread-4| I120: Preprocessed UTS_RELEASE, got value "3.19.0-10-generic".
2015-04-05T13:39:04.205+05:30| vthread-4| I120: The header path "/lib/modules/3.19.0-10-generic/build/include" for the kernel "3.19.0-10-generic" is valid.  Whoohoo!
2015-04-05T13:39:04.206+05:30| vthread-4| I120: Found compiler at "/usr/bin/gcc"
2015-04-05T13:39:04.208+05:30| vthread-4| I120: Got gcc version "4.9.2".
2015-04-05T13:39:04.208+05:30| vthread-4| I120: The GCC version matches the kernel GCC minor version like a glove.
2015-04-05T13:39:04.208+05:30| vthread-4| I120: Using user supplied compiler "/usr/bin/gcc".
2015-04-05T13:39:04.210+05:30| vthread-4| I120: Got gcc version "4.9.2".
2015-04-05T13:39:04.210+05:30| vthread-4| I120: The GCC version matches the kernel GCC minor version like a glove.
2015-04-05T13:39:04.212+05:30| vthread-4| I120: Trying to find a suitable PBM set for kernel "3.19.0-10-generic".
2015-04-05T13:39:04.212+05:30| vthread-4| I120: No matching PBM set was found for kernel "3.19.0-10-generic".
2015-04-05T13:39:04.212+05:30| vthread-4| I120: The GCC version matches the kernel GCC minor version like a glove.
2015-04-05T13:39:04.212+05:30| vthread-4| I120: Validating path "/lib/modules/3.19.0-10-generic/build/include" for kernel release "3.19.0-10-generic".
2015-04-05T13:39:04.212+05:30| vthread-4| I120: Failed to find /lib/modules/3.19.0-10-generic/build/include/linux/version.h
2015-04-05T13:39:04.212+05:30| vthread-4| I120: /lib/modules/3.19.0-10-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-04-05T13:39:04.212+05:30| vthread-4| I120: using /usr/bin/gcc-4.9 for preprocess check
2015-04-05T13:39:04.216+05:30| vthread-4| I120: Preprocessed UTS_RELEASE, got value "3.19.0-10-generic".
2015-04-05T13:39:04.216+05:30| vthread-4| I120: The header path "/lib/modules/3.19.0-10-generic/build/include" for the kernel "3.19.0-10-generic" is valid.  Whoohoo!
2015-04-05T13:39:04.224+05:30| vthread-4| I120: The GCC version matches the kernel GCC minor version like a glove.
2015-04-05T13:39:04.224+05:30| vthread-4| I120: Validating path "/lib/modules/3.19.0-10-generic/build/include" for kernel release "3.19.0-10-generic".
2015-04-05T13:39:04.224+05:30| vthread-4| I120: Failed to find /lib/modules/3.19.0-10-generic/build/include/linux/version.h
2015-04-05T13:39:04.224+05:30| vthread-4| I120: /lib/modules/3.19.0-10-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-04-05T13:39:04.224+05:30| vthread-4| I120: using /usr/bin/gcc-4.9 for preprocess check
2015-04-05T13:39:04.228+05:30| vthread-4| I120: Preprocessed UTS_RELEASE, got value "3.19.0-10-generic".
2015-04-05T13:39:04.228+05:30| vthread-4| I120: The header path "/lib/modules/3.19.0-10-generic/build/include" for the kernel "3.19.0-10-generic" is valid.  Whoohoo!
2015-04-05T13:39:04.228+05:30| vthread-4| I120: Using temp dir "/tmp".
2015-04-05T13:39:04.229+05:30| vthread-4| I120: Obtaining info using the running kernel.
2015-04-05T13:39:04.229+05:30| vthread-4| I120: Setting header path for 3.19.0-10-generic to "/lib/modules/3.19.0-10-generic/build/include".
2015-04-05T13:39:04.229+05:30| vthread-4| I120: Validating path "/lib/modules/3.19.0-10-generic/build/include" for kernel release "3.19.0-10-generic".
2015-04-05T13:39:04.229+05:30| vthread-4| I120: Failed to find /lib/modules/3.19.0-10-generic/build/include/linux/version.h
2015-04-05T13:39:04.229+05:30| vthread-4| I120: /lib/modules/3.19.0-10-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-04-05T13:39:04.229+05:30| vthread-4| I120: using /usr/bin/gcc-4.9 for preprocess check
2015-04-05T13:39:04.233+05:30| vthread-4| I120: Preprocessed UTS_RELEASE, got value "3.19.0-10-generic".
2015-04-05T13:39:04.233+05:30| vthread-4| I120: The header path "/lib/modules/3.19.0-10-generic/build/include" for the kernel "3.19.0-10-generic" is valid.  Whoohoo!
2015-04-05T13:39:04.336+05:30| vthread-4| I120: found symbol version file /lib/modules/3.19.0-10-generic/build/Module.symvers
2015-04-05T13:39:04.336+05:30| vthread-4| I120: Reading symbol versions from /lib/modules/3.19.0-10-generic/build/Module.symvers.
2015-04-05T13:39:04.352+05:30| vthread-4| I120: Read 18765 symbol versions
2015-04-05T13:39:04.352+05:30| vthread-4| I120: Invoking modinfo on "vmnet".
2015-04-05T13:39:04.354+05:30| vthread-4| I120: "/sbin/modinfo" exited with status 256.
2015-04-05T13:39:04.667+05:30| vthread-4| I120: Setting destination path for vmnet to "/lib/modules/3.19.0-10-generic/misc/vmnet.ko".
2015-04-05T13:39:04.667+05:30| vthread-4| I120: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
2015-04-05T13:39:04.671+05:30| vthread-4| I120: Successfully extracted the vmnet source.
2015-04-05T13:39:04.671+05:30| vthread-4| I120: Building module with command "/usr/bin/make -j8 -C /tmp/modconfig-r28NAC/vmnet-only auto-build HEADER_DIR=/lib/modules/3.19.0-10-generic/build/include CC=/usr/bin/gcc IS_GCC_3=no"
2015-04-05T13:39:05.864+05:30| vthread-4| W110: Failed to build vmnet.  Failed to execute the build command.
2015-04-05T13:40:27.615+05:30| vthread-4| I120: The GCC version matches the kernel GCC minor version like a glove.
2015-04-05T13:40:27.615+05:30| vthread-4| I120: Validating path "/lib/modules/3.19.0-10-generic/build/include" for kernel release "3.19.0-10-generic".
2015-04-05T13:40:27.615+05:30| vthread-4| I120: Failed to find /lib/modules/3.19.0-10-generic/build/include/linux/version.h
2015-04-05T13:40:27.615+05:30| vthread-4| I120: /lib/modules/3.19.0-10-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-04-05T13:40:27.615+05:30| vthread-4| I120: using /usr/bin/gcc-4.9 for preprocess check
2015-04-05T13:40:27.620+05:30| vthread-4| I120: Preprocessed UTS_RELEASE, got value "3.19.0-10-generic".
2015-04-05T13:40:27.620+05:30| vthread-4| I120: The header path "/lib/modules/3.19.0-10-generic/build/include" for the kernel "3.19.0-10-generic" is valid.  Whoohoo!
2015-04-05T13:40:27.620+05:30| vthread-4| I120: Using temp dir "/tmp".
2015-04-05T13:40:27.620+05:30| vthread-4| I120: Obtaining info using the running kernel.
2015-04-05T13:40:27.620+05:30| vthread-4| I120: Setting header path for 3.19.0-10-generic to "/lib/modules/3.19.0-10-generic/build/include".
2015-04-05T13:40:27.620+05:30| vthread-4| I120: Validating path "/lib/modules/3.19.0-10-generic/build/include" for kernel release "3.19.0-10-generic".
2015-04-05T13:40:27.620+05:30| vthread-4| I120: Failed to find /lib/modules/3.19.0-10-generic/build/include/linux/version.h
2015-04-05T13:40:27.620+05:30| vthread-4| I120: /lib/modules/3.19.0-10-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2015-04-05T13:40:27.620+05:30| vthread-4| I120: using /usr/bin/gcc-4.9 for preprocess check
2015-04-05T13:40:27.625+05:30| vthread-4| I120: Preprocessed UTS_RELEASE, got value "3.19.0-10-generic".
2015-04-05T13:40:27.625+05:30| vthread-4| I120: The header path "/lib/modules/3.19.0-10-generic/build/include" for the kernel "3.19.0-10-generic" is valid.  Whoohoo!
2015-04-05T13:40:27.725+05:30| vthread-4| I120: found symbol version file /lib/modules/3.19.0-10-generic/build/Module.symvers
2015-04-05T13:40:27.725+05:30| vthread-4| I120: Reading symbol versions from /lib/modules/3.19.0-10-generic/build/Module.symvers.
2015-04-05T13:40:27.741+05:30| vthread-4| I120: Read 18765 symbol versions
2015-04-05T13:40:27.741+05:30| vthread-4| I120: Invoking modinfo on "vmnet".
2015-04-05T13:40:27.743+05:30| vthread-4| I120: "/sbin/modinfo" exited with status 256.
2015-04-05T13:40:28.060+05:30| vthread-4| I120: Setting destination path for vmnet to "/lib/modules/3.19.0-10-generic/misc/vmnet.ko".
2015-04-05T13:40:28.060+05:30| vthread-4| I120: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
2015-04-05T13:40:28.064+05:30| vthread-4| I120: Successfully extracted the vmnet source.
2015-04-05T13:40:28.064+05:30| vthread-4| I120: Building module with command "/usr/bin/make -j8 -C /tmp/modconfig-miev7l/vmnet-only auto-build HEADER_DIR=/lib/modules/3.19.0-10-generic/build/include CC=/usr/bin/gcc IS_GCC_3=no"
2015-04-05T13:40:29.359+05:30| vthread-4| W110: Failed to build vmnet.  Failed to execute the build command.

The penultimate line shows that it is unpacking the vmnet-only directory where the changed filter.c file lives, but it seems that the changed file is not helping. Any help would be appreciated.

  • I know that there are more issues. 1) It is trying to start some services with Upstart while Ubuntu 15.04 completely switched to systemd and VMWare fails to start the services. 2) It fails to compile the new kernel(which is not a big issues, won't be able to share folders between host and guest os - alternative is to share the files through samba) – Lilian A. Moraru Apr 6 '15 at 7:35
up vote 7 down vote accepted

I am on 14.10 64-bit. Kernel 3.19. The following steps worked for me under VMware Worstation 11 and VMware Player 7.1.0: https://wiki.archlinux.org/index.php/VMware#3.19_kernels

  • Works like a charm -- thank you. – tchakravarty Apr 7 '15 at 5:03
  • That worked perfectly. Thank you! – naisanza Apr 30 '15 at 16:11

I've resolved the issue with the following steps:

curl http://pastie.org/pastes/9934018/download -o /tmp/vmnet-3.19.patch

cd /usr/lib/vmware/modules/source
tar -xf vmnet.tar
patch -p0 -i /tmp/vmnet-3.19.patch
tar -cf vmnet.tar vmnet-only
rm -r *-only
vmware-modconfig --console --install-all

I had the same issue, patches etc. did not work. Ran sudo apt-get update & sudo apt-get upgrade. Still not working and unable to access my VM for a couple of months. Today I completely removed VMWare player

sudo vmware-installer -u vmware-player

and downloaded the latest 7.1.2 bundle from https://my.vmware.com/web/vmware/free#desktop_end_user_computing/vmware_player/7_0 selecting Minor version 7.1.2 (latest)

sh VMware-Player-7.1.2-2780323.x86_64.bundle

Installed and working fine, I am now able to access the VM I was working on prior to upgrading ubuntu to 15.04.

  • before adding or removing software it is good practice to run sudo apt-get update to ensure that all the software on your computer is synchronised with the latest versions available – Dom Page Aug 20 '15 at 16:06
  • This is explanation is obsolete after you edited your post and changed sudo update to sudo apt-get update. – Karl Richter Aug 21 '15 at 13:23

http://rglinuxtech.com/?p=1281 This is the source information that the archlinux patch came from. There's also an issue with netif.c now that causes a failure and requires a separate edit to fix before retarring up the vmnet.tar file.

I'm hoping/assuming that vmware will just come out with a bug fix release in the next few days so people don't have to jump through these hoops.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.