I'm trying to purge Deluge so I can use KTorrent, because Deluge stopped working. Every time I start a download, it gives me an error message. I tried downloading Ktorrent without purging Deluge to give it a try, but the torrents always go back to Deluge as a default. So I purged it in Terminal. The problem is it still appears. Terminal says I don't have Deluge anymore. The Ubuntu Applications center also says I don't have it installed anymore. But when I search applications, lo and behold, Deluge still sitting there. Any when I download a torrent, it opens right back up in Deluge and continues to get blocked by the same error. I tried changing the default downloader in Chrome, but couldn't figure that out either.

  • try sudo aptitude purge packagename and sudo apt-get autoremove see also askubuntu.com/questions/187888/… and also see this askubuntu.com/questions/132967/…
    – Aravinda
    Apr 5, 2015 at 8:29
  • i dropped into root and purged it there, and it worked
    – Push
    Apr 5, 2015 at 9:10
  • previously you tried without sudo ?
    – Aravinda
    Apr 5, 2015 at 9:21
  • I wish i would have written down what I did, because now I forgot. I had been using sudo, but it didn't work because i wasn't in root... I think. I was in username@username-All-series:~$
    – Push
    Apr 5, 2015 at 9:42
  • i saw a post about something unrelated, that had a command line like sudo -i or something with -i, and when i did that it dropped me to root@username.... and when I purged from there, it worked well.
    – Push
    Apr 5, 2015 at 9:43


You must log in to answer this question.

Browse other questions tagged .