5

I have formatted USB stick and now I can't mount it.

Command sudo fdisk -l outputs this (shortened to only show info about sdc and sdc1):

Disk /dev/sdc: 8075 MB, 8075120640 bytes
64 heads, 32 sectors/track, 7701 cylinders, total 15771720 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x22fb6a74

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           0      407551      203776   17  Hidden HPFS/NTFS

Disk /dev/sdc1: 208 MB, 208666624 bytes
64 heads, 32 sectors/track, 199 cylinders, total 407552 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x22fb6a74

     Device Boot      Start         End      Blocks   Id  System
/dev/sdc1p1   *           0      407551      203776   17  Hidden HPFS/NTFS

If I try to mount sdc1 with sudo mount -t ntfs /dev/sdc1 /mnt the output is:

NTFS signature is missing.
Failed to mount '/dev/sdc1': Invalid argument
The device '/dev/sdc1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

EDIT:

Output of command sudo lsblk -f is:

NAME   FSTYPE LABEL MOUNTPOINT
sda                 
├─sda1 ext4         /
├─sda2              
└─sda5 swap         [SWAP]
sdb                 
├─sdb1              
└─sdb5 ext4         /media/disc_d
sdc                 
└─sdc1              
sr0 
  • Try sudo mount /dev/sdc1 /mnt -o uid=1000 , without the -t options. Let me know if works, i will convert it to answer – Sergiy Kolodyazhnyy Apr 4 '15 at 18:09
  • unplug it and plug it back in to automount – mchid Apr 4 '15 at 18:19
  • Result of Serg's command is: mount: you must specify the filesystem type – Cikson Apr 4 '15 at 19:04
  • Are you sure, that sdc1 actually contains a NTFS? Please verify with sudo blkid /dev/sdc1 or more generally sudo lsblk -f. – David Foerster Apr 4 '15 at 19:16
  • what is the result for dpkg -l | grep ntfs | grep ii # if there is no output, then you need to install – Aravinda Apr 4 '15 at 19:22
5

You formatted the USB disk wrongly: it has a Hidden HPFS/NTFS partition.

  1. Open gparted
  2. Navigate to the correct disk in the upper right corner:

enter image description here

  1. Go to device and choose create partition table and choose msdos
  2. Right-click the large empty square in the middle:

enter image description here

and choose "format to" and take FAT32

Done! ;-)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.