13

This question already has an answer here:

I have recently installed nemo with:

sudo apt-get install nemo

But I am finding that other applications still are using nautilus to open folders like for instance the Unity search still opens its search results and folders in nautilus. So is there any way that I can get it to use nemo as default (at least the search)?


OS Information:

Description:    Ubuntu 14.10
Release:    14.10

Package Information:

Nautilus:

nautilus:
  Installed: 1:3.10.1-0ubuntu15.1
  Candidate: 1:3.10.1-0ubuntu15.1
  Version table:
 *** 1:3.10.1-0ubuntu15.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ utopic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.10.1-0ubuntu15 0
        500 http://gb.archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages

Nemo:

nemo:
  Installed: 2.2.4-1
  Candidate: 2.2.4-1
  Version table:
 *** 2.2.4-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ utopic/universe amd64 Packages
        100 /var/lib/dpkg/status

marked as duplicate by Wilf, Community Jun 23 '15 at 9:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

14

Before changing defaults system-wide, you should thoroughly test something like a new file manager in one of your users first by adding nemo as the default file manager in the start-up applications...

One user:

Go to the dash, then type startup applications and add: by using nemo -n in the command.

Then disable Nautilus from drawing the desktop icons by executing:

gsettings set org.gnome.desktop.background show-desktop-icons false

Log out and log back in and you'll see two identical "files" icons in the unity launcher. Unlock the top one and lock the bottom one and move it to the top below the icon for the dash. Then allow nemo to draw the desktop icons for you:

gsettings set org.nemo.desktop show-desktop-icons true

All users:

Execute the following command:

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

and then edit /etc/mime.types and carefully review if nothing is left of nautilus. If it is, replace it by nemo.

reboot afterwards.

  • You can also set nemo to manage the icons, using something like gsettings set org.nemo.desktop show-desktop-icons true – Wilf Jun 22 '15 at 23:39
  • @Wilf: Answer edited. Thanks for the info (and don't be afraid to edit my answers yourself next time!) ;-) – Fabby Jun 23 '15 at 7:01
  • 1
    @dn-ʞɔɐqɹW I just fixed the gsettings command mentioned above – Corey Goldberg Feb 17 '16 at 13:58
  • 2
    I tried this solution, and afterwards my wallpaper was not showing anymore. Any way to resolve this? – BNJMNDDNN Oct 18 '16 at 17:01
  • 1
    the file dialogs are from GTK toolkit, not from nemo or nautilus. – jms Sep 21 '17 at 16:28