0

I have repeatedly installed Ubuntu 14.04.2 desktop i386 alongside Windows XP on my Dell Dimension 2400 several times in the past several days and each time the installation claims that it has completed and needs to restart. I click the onscreen Restart button (after it has been there for about 30 minutes since it is such a slow computer) and watch Ubuntu go through the shutdown process and eject the CD/DVD. At this point,it seems obvious that everything has completed and is waiting for me to power down the pc and power it back up. So I power it down, wait at least 10 seconds, then power it back up. The system eventually posts the following message onscreen:

error: no such device: e75b8f4c-36e0-4af6-a656-3dc7311770da. Entering rescue mode... grub rescue>

So I then type the ls command and receive the following information:

(hd0) (hd0,msdos1) (hd1) (hd1,msdos1) (fd0)

What should this Ubuntu newbie do to resolve this problem and successfully boot into either Windows XP or Ubuntu 14.04.2 desktop i386? I am at a loss and do not know what to try next to resolve this ongoing problem. I have already wasted days of attempts.

My CPU is a Pentium 4 2.66 GHz with a 512 kB cache. My RAM is 1 GB.

Can anyone help me please?

I booted from the Ubuntu 14.04.2 desktop i386 CD/DVD and chose Try Ubuntu in order to boot successfully to try to answer your questions oldfred. I accepted the default Ubuntu suggestion for creating partitions on my existing 1.5TB hdd that was already formatted NTFS with Windows XP. As I recall, Ubuntu created a partition for a swap file and a partition for something else, but due to being such a newbie, I trusted the suggested defaults. I tried to post sudo parted -1 at the grub rescue prompt but it did not work so I tried typing it again at a terminal prompt. I need to correct what I said earlier about the boot drive. The boot drive was prior to Ubuntu installation a 120 GB named OS and it has 70.4 GB used and 49.6 GB free. Ubuntu lists it's Location as media/ubuntu and it's Volume as OS. There is also now an 82 GB Volume listed that appears to be an Ubuntu volume. It's Name is listed as the number that was listed in the message regarding "no such device". It shows 3.8 GB used and 72.8 GB free and Filesystem type as ext3/ext4.

I typed sudo parted -l at the prompt in a terminal window and received a ton of information that I am going to try to post here as a screenshot.

7
  • 1
    Some older BIOS have issues booting from larger partitions. Or all boot files must be in the first 137GB of drive. Is that how you installed with either a /boot at beginning of drive or a 20 or 25GB / (root) partition at beginning of drive (or fully inside first 137GB) and /home or data partitions for rest of drive? Post this: sudo parted -l
    – oldfred
    Apr 3, 2015 at 23:33
  • I booted from the Ubuntu 14.04.2 desktop i386 CD/DVD and chose Try Ubuntu in order to boot successfully to try to answer your questions. Apr 3, 2015 at 23:41
  • 1
    The first thing to try is boot-repair. Since you can boot the live CD, use option 2 at this link. If it completes successfully, accept the suggested repair. This helps in many cases. help.ubuntu.com/community/Boot-Repair Apr 4, 2015 at 0:21
  • This may be helpful: linux.com/learn/tutorials/… - read the "booting from grub-rescue>" section in particular (I would read all of it).
    – user371765
    Apr 4, 2015 at 2:47
  • If running Boot-Repair, just post the link it gives for its Summary report. That shows a lot of detail. But is this a new larger hard drive on an older system where BIOS may not like that large of a drive?
    – oldfred
    Apr 4, 2015 at 3:30

1 Answer 1

0

Welcome to Ubuntu! You do not describe the installation process much but that is where I recommend you focus on solving the problem. It is easier to follow Canonicals simplified procedure that repair/rebuild the a broken system.

Check to make sure that when you get the the step where you setup the partitions that you select to install the bootloader to the hard drive, not a partition. For example, if your laptop hard drive is hda, windows is on hda1, and you are putting ubuntu on hda2, the bootloader should be installed on hda, not hda2 (nor hda1).

This question touches on this.

Also, in general, this is a great resource for setting up your dual boot machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .