I have installed ROS fuerte and established a connection between the LEGO NXT and my PC's ROS through 2 terminals. I start ROS with the command roscore

The problem is that when I run a command to start some sensor of the LEGO, for exampled:

rosrun nxt_python touch_sensor_test.py 

the terminal says:

[rospack] Error: stack/package nxt_python not found

And I can't do anything with the LEGO.

I have tried downloading nxt_python for Ubuntu 12.04 and tried to install it and it doesn't work.

What's the problem and how can I fix it?

  • Welcome to AU! Unfortunately your question is in a terrible state. It's very hard to understand, what the issue is. It appears, that you need to install the Python module nxt_python from the package nxt-python, but there seems to be some problem, that you don't mention. It's good to mention the overall purpose of your endeavour, but I think you spent far to much words on it compared to the actual problem. Please edit your question and try to cut down the borderline related parts and clarify the information on the core issue. See How do I ask a good question?. Apr 3, 2015 at 21:05
  • @DavidFoerster any better now?
    – Zanna
    Jul 13, 2018 at 7:46
  • @Zanna: Thanks for the edit! The question is understandable now but it still lacks information, e. g. installation error messages. Jul 13, 2018 at 9:20
  • @DavidFoerster agreed - I would have voted to close it as unclear, but you answered it...
    – Zanna
    Jul 13, 2018 at 9:20

1 Answer 1


As you seem to have noticed yourself, you need the Python module nxt_python from the package nxt-python, which you can install with

sudo apt-get install nxt-python

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .