0

I'm trying to install this because Nouveau / the default driver, is unstable for me, and eventually results in GPU lockups unless I'm running low graphic mode.

Got this error while trying to install the 173.x Nvidia binary driver, downloaded from their site. I have an nForce 430, the newest driver available for it is the 304.x, which is available in the Additional Software, but results in an ACPI error on startup. Someone else suggested that nForce support wasn't very good in some of the later drivers, and I should try the 173.x instead, which is also available through the Additional Software. However, when I select it and click apply changes, nothing happens. It just reverts right back to having the x.org driver selected. So, I'm trying it through tty.

I've checked, and I have the appropriate headers installed for my kernel version. Even tried installing sources, just to be sure.

I'm using tty1 Ctrl+Alt+F1, and I've stopped lightdm service prior to installing.

Also, just a quick question? What is the difference in using for Terminal, Ctrl+Alt+F1 versus F2 or F3 .

4
  • That is not the way to install the nvidia driver. see help.ubuntu.com/community/BinaryDriverHowto/Nvidia .If you must compile the binary yourself you will have to file a bug report with Nvidia – Panther Apr 3 '15 at 15:16
  • do you actually have it installed apt-cache policy nvidia-173? – JoKeR Apr 3 '15 at 15:48
  • That's the way I've read to do it in every single guide so far. And what you provided doesn't say anything contradictory to that.. – Parker King Apr 4 '15 at 5:50
  • No Joker, that's what I'm trying to do. – Parker King Apr 4 '15 at 5:51
1

Well, I've tested lots of nvidia drivers on different cards as a fan of nvidia and to tell you the truth 173 version is not fully compatible or tested with Ubuntu 14.04LTS, that's why you get:

..Error - “Kernel module failed to build

Happened to me too, though I have managed to install 173 driver on Ubuntu 12.04LTS it was working and seemed to be fine but it's uncompatible with newer Linux kernels starting off 14.04.2LTS point release it uses Utopic default kernel, so you'll have only to downgrade the system and that's a big mess, you'll face issues with dependencies in the future.

What I can suggest you to install 304.119 driver on Ubuntu 14.04.1 not 2 it worked fine. Or install 12.04LTS. But if you have nvidia 6500 series and up at least the newest available driver version 304.125 will be working just fine.

Also, you can use my workaround on how to install nvidia driver

1

With a passmark of 22, you're better off ditching the card entirely and moving to a low-end version of Ubuntu like Lubuntu as you will have virtually no benefits of installing such an old driver with such an old card.

Sorry to be the harbinger of bad news... :-(

4
  • Well I appreciate that though, the most recent driver that supports my GPU is the 304.x. – Parker King Apr 7 '15 at 3:29
  • Sorry! I've edited my answer. – Fabby Apr 7 '15 at 11:08
  • Is Ubuntu not less intensive than Windows 7? Because I've been using Windows 7 fine on it. – Parker King Apr 8 '15 at 14:04
  • Lubuntu and Xubuntu are, Ubuntu is not! – Fabby Apr 8 '15 at 19:20
0

Today, I faced similar error, after attempting to update Nvidia drivers. It turned out that the problem was caused by different compiler used to build the kernel module.

Recently I've set gccto be associated with gcc-6. As it turns out - this isn't the right version to build kernel modules, at least at Ubuntu 14.04 LTS. I simply reconfigured gcc alternatives with sudo update-alternatives --config gcc to point gcc-5 and then reinstalled the Nvidia driver, using sudo apt-get purge nvidia* followed by sudo ubuntu-drivers autoinstall.

Although this answer may be little off topic here, I hope it will be helpful for someone, searching the same keywords I did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.