2

Modern keyboards come with a bunch of crap and useless buttons but often few media keys.

My current one has play/pause, vol +/- and calculator only.

I would like to remap the XF86Calculator button to be "next track" but it just keeps bringing up the calculator as normal. The next track button is not pressed.

I have one successful mapping which sets the Pause button to trigger the command xdotool key XF86AudioPlay

Some others will work XF86Back, insert, letter keys.

I cannot remap some keys to the exact same operations, including the calculator button. I am using the key capture function so I know the XF86 code is correct

Any ideas?

  • By "calculator", did you mean "numpad", or it is really a calculator button? – Andrew T. Apr 3 '15 at 13:24
  • It's a calculator button XF86Calculator – cassiopeia Apr 3 '15 at 14:34
  • 1
    Have you tried going into System Settings - keyboard - shortcuts and to disable the calculator there first before trying to re-define it??? Please feed back so I can convert this to an answer... ;-) – Fabby Apr 9 '15 at 8:57
  • That worked at first. Now any of the keys I edit in the keyboard editor break permanently. I have rebooted. – cassiopeia Apr 9 '15 at 20:46
1

Very much a workaround but I have instead used compizconfig to map these keys to CLI commands for banshee rather than trying to use the media keys.

Works 100% in banshee therefore but no use if you're using other media players.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.