0

I would like to ask you for help with my WiFi connection. My problem looks like this:

  • After I turn on my laptop or after reboot everything works fine.

But after suspend my WiFi works about 6 minutes and then stops responding. It looks like it's connected but it doesn't respond. It is happening in all networks.

After I turn on/off wifi, it works for the next 6 minutes. After reboot all is fine until the next suspend.

I am on ubuntu 14.04 and my laptop is lenovo G50-70

when I add this :

sudo rfkill list 

it shows this

0: ideapad_wlan: Wireless LAN 
    Soft blocked: no
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  • Is there any one can help my ??? – prens juba Apr 5 '15 at 10:08
  • Welcome to Ask Ubuntu! ;-) Could you please go to a terminal by pressing [Ctrl][Alt][T] and type lspci&&lsusb. Then edit your question and copy-paste the output of the command into your question. – Fabby Apr 8 '15 at 20:04
  • Did not give any answer. And gives the wrong question – prens juba Apr 23 '15 at 22:18
0

This happens because this laptop has no wireless hardware switch. Kernel driver can't handle this right. I made a ppa with a patched ideapad-laptop driver. Patch is queued upstream, but it will take time to get into stable kernels. The driver can be installed by

sudo add-apt-repository ppa:hanipouspilot/ideapad-laptop
sudo apt-get update
sudo apt-get install ideapad-laptop

Wireless must work after reboot.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.