2

I'm installing Openstack using openstack-install (MAAS+juju+landscape), and I got stuck on the first bootstrap forever.
After some troubleshooting I realize the problem was DNS.
On the bootstrap machine, the DNS is MAAS IP, which is good, but that DNS didn't have internet name resolution. What to do? forwarders, right?
I found Ubuntu MAAS DNS not forwarding request and did something like that and worked... for a while.

Basically what I did, was to modify from "auto" to "no" in this line in /etc/bind/named.conf.options:

dnssec-validation no;

And I added this line:

forwarders { 192.168.10.7 ; };

Restart bind9 and name resolution worked fine. The problem is after "something" (probably something I touched on MAAS), the forwarder line disappeared.

This is what happened on the bootstrap without forwarder on the MAAS DNS:

ubuntu@marin:~$ ping www.emol.com
ping: unknown host www.emol.com

And this when I added the forwarder:

ubuntu@marin:~$ ping www.emol.com
PING ip11.yah.cl (200.12.20.11) 56(84) bytes of data.
64 bytes from 200.12.20.11: icmp_seq=1 ttl=245 time=8.01 ms
64 bytes from 200.12.20.11: icmp_seq=2 ttl=245 time=7.62 ms

Now the questions:

  1. Why on the Boostrap's DNS appears only the MAAS server's IP if I configure multiple DNS in MAAS -- Networks -- Edit internal network -- DNS Servers (I used spaces between DNS Servers)
  2. How can I configure forwarders on MAAS DNS (maybe on the GUI or thru MAAS CLI commands)?

PS: I'm using MAAS version 1.7.2+bzr3355-0ubuntu1~trusty1

2

1) Could be a possible bug, the MAAS UI should support multiple entries.

2) You'll need to make your changes within /etc/bind/maas/named.conf* as those files are included into the top level named options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.