Friend's old laptop running ubuntu has 'died' (too old to be worth repairing), but he wanted to save some family photos from the hard drive, so I took the drive out and connected it to my laptop(running ubuntu 11.04) with an IDE-to-USB adapter.

  1. How do I get permissions to access all the files on the filesystem? I tried with sudo chown -R username /dev/devicename, sudo chmod -R 755 /dev/devicename, but it doesn't work. I also tried booting the whole system from the USB-connected drive, but it doesn't seem to work either.
  2. There seems to be nothing inside the /home folder. Is this because I don't have permissions to view the content, or does this mean that the hard drive is corrupt/there's nothing there and all my effort is in vain anyway?
  • I have some questions: Could you describe what died exactly means? What happend when you connected the drive to your computer? Was it mounted automatically or did you mount it? It would be helpful to see the mountpoint of the /home. So please paste the output of the command grep home /etc/fstab. – qbi Sep 7 '11 at 22:13

You'll have to set the filesystem permissions on the filesystem, not the block device. So, you'll run chmod on /media/mountpoint, not on /dev/sdx. In any case, root always has complete access to everything, so if you run gksudo nautilus, you won't have any problems accessing any files.

It is not unusual for users to have the /home on a different partition. This enables you to reinstall Ubuntu without loosing any personal files or settings. That may be the case. You should look through the other partitions and see what they contain.

You can run a smart-test on the drive to see how badly damaged it is. From what information you provide, it is not possible to know much about the state of the disks. "died" doesn't say anything at all.

|improve this answer|||||
  • @qbi by died I meant - the laptop didn't respond when powered on, no lights went on,no sound,nothing - i assumed a motherboard failure or something like that. the drive works fine as far as I can tell, it mounted automatically, I was just surprised to find /home empty. em, grep home /etc/fstab returns nothing... and that's the only partition on the drive, it's an ext4, checked with Gparted. – mnb Sep 7 '11 at 22:35
  • I haven't personally tested a disk with Gparted, so I don't know what it does. What I can recommend is to use the "disk tool" or whatever its label is. It's actual name is "palimpsest" and it's installed by default. It will enable you to run tests on the disk, far beyond a simple surface scan. You can also use smartctl from the package smartmontools, but it's CLI only. As far as I'm aware, palimpsest does the same thing but with a good GUI. – Jo-Erlend Schinstad Sep 7 '11 at 22:52
  • gparted is the GUI front end to parted, it's a partitioner – Matt Sep 7 '11 at 23:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.