This question already has an answer here:

I purchased a Dell Inspiron 7746 notebook, and have installed Ubuntu 14.10 on alongside Windows.

All has worked well so far, but I am having a frustrating getting the trackpad to work correctly. The trackpad worked great when running from the Live CD, but once I actually installed the OS, I found that it's operation to be undesirable.

Here are the issues I am having:

  • Tap to click does not work. Clicks are only registered when pressing the clickpad
  • Two-finger tap to right-click does not work. In fact, right-clicking is not possible at all. Pressing the clickpad in the right-click area does not register as a right-click.
  • Two finger scrolling does work, however, after scrolling, any single finger trackpad action is also registered as a scroll. The only way to fix this is to two-finger scroll again.
  • Trackpad does not disable while typing.

Here are some of the workarounds I have tried after doing some googling:

  • Ran synclient tapbutton 1=1
  • Added Option "TapButton1" "1" to 50-synaptics.conf
  • Did a fresh install of 14.10 (several times, actually)

Perhaps the most frustrating thing about this is that the trackpad works beautifully on the live CD, just not when the OS is installed. Using a wireless USB mouse now, but would love to get this issue resolved. Thanks!

marked as duplicate by Zanna, Charles Green, Eric Carvalho, karel, Elder Geek Jul 22 '17 at 20:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Working now! Found a solution on this question:

Trackpad not working when updated to Ubuntu 14.10

In the terminal, type:

sudo vi /etc/modprobe.d/blacklist_i2c_hid.conf`

then type the following into that file.

blacklist i2c_hid

Save the file and restart your system, now check whether the touchpad is working fine

Not the answer you're looking for? Browse other questions tagged or ask your own question.