11

I would like to remove several of the Indicators that usually appear in the upper-right-hand side of the login screen. In particular, I would like to remove the accessibility, keyboard layout, power, and sound indicators, although it would be nice to know how to generically add or remove indicators. How can I do this?

  • You are using Unity-greeter? There should be a config file in /etc/lightdm/, but I don't remember which one and can't check as I am sitting on a Windows machine at the moment. Read all files - At least one should contain a section about the indicators you mentioned. Copy the file as backup and find out how to edit it. Or post its content (as edit to your question!) and I will have a look. You have to leave me a comment (@ByteCommander) then... – Byte Commander Apr 2 '15 at 22:43
  • 1
    What's the system you're using ? 14.04 ? – Sergiy Kolodyazhnyy May 11 '15 at 6:47
  • @Serg, yes, I'm using 14.04. – fouric May 12 '15 at 4:15
  • @ByteCommander, there are four greeter configuration files in my /etc/lightdm: lightdm.conf, lightdm-gtk-greeter.conf, lightdm-gtk-greeter-ubuntu.conf, and lightdm-webkit-greeter.conf. I have no idea what the difference between any of them is, but I did try to disable the login screen clock through each of them, and it didn't work. – fouric May 13 '15 at 2:41
  • I am on 15.04 now and am afraid that I seem to have none of these config files any more... Could you upload your four config files (to pastebin.com for example) and share the link? I could look over them and see if they look about as I remember mine. – Byte Commander May 13 '15 at 20:08
6
+50

Coming with different approach:

$ pstree
init─┬─...
     ├─lightdm─┬─Xorg
     │         ├─lightdm─┬─lightdm-greeter───unity-greeter───4*[{unity-greeter}]
     ...

$ dpkg -L unity-greeter
...
/usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml
...

$ more /usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml

...
    <key name="indicators" type="as">
      <default>['ug-accessibility', 'com.canonical.indicator.keyboard', 'com.canonical.indicator.session', 'com.canonical.indicator.datetime', 'com.canonical.indicator.
power', 'com.canonical.indicator.sound', 'application']</default>
      <summary>Which indicators to load</summary>
    </key>
...

unity-greeter is run by lightdm user! Instead of looking around for a way to change the dconf setting for that ghost user. I override the default. Tested in Ubuntu 14.04 64bit (VirtualBox).

  1. Create new dconf override file

    sudo nano /usr/share/glib-2.0/schemas/90_unity-greeter.gschema.override
    

    Put these two lines in it with indicator you want to keep:

    [com.canonical.unity-greeter]
    indicators=['com.canonical.indicator.session']
    

    Default is:

    ['ug-accessibility', 'com.canonical.indicator.keyboard', 'com.canonical.indicator.session', 'com.canonical.indicator.datetime', 'com.canonical.indicator.power', 'com.canonical.indicator.sound', 'application']
    
  2. Recompile glib schemas

    sudo glib-compile-schemas /usr/share/glib-2.0/schemas/
    
  3. Restart the display manager

    sudo service lightdm restart
    
| improve this answer | |
  • 1
    This one allows me to remove the accessibility (ug-accessibility) and wireless (application) indicators. Between this answer and your previous one, it is now possible to remove every one of the preinstalled indicators. – fouric May 15 '15 at 21:13
  • @InkBlend, Actually this covers all indicators with single setting point. No need for my other partial solution – user.dz May 16 '15 at 7:54
8

One way that I have tried in Ubuntu 14.04 using LightDM (Default); Using Some config files stored in /usr/share/unity/indicators/

Let's say you want to hide keyboard indicator:

  1. Open corresponding file for editing

    sudo nano /usr/share/unity/indicators/com.canonical.indicator.keyboard
    
  2. Comment object paths for the mode you want to hide in, example this will hide it in the greeting screen and lock screen

    [Indicator Service]
    Name=indicator-keyboard
    ObjectPath=/com/canonical/indicator/keyboard
    Position=80
    
    [desktop]
    ObjectPath=/com/canonical/indicator/keyboard/desktop
    
    #[desktop_greeter]
    #ObjectPath=/com/canonical/indicator/keyboard/desktop_greeter
    
    #[desktop_lockscreen]
    #ObjectPath=/com/canonical/indicator/keyboard/desktop_lockscreen
    
    [ubiquity]
    ObjectPath=/com/canonical/indicator/keyboard/desktop
    
  3. Reboot or just restart display manager

    sudo service lightdm restart
    
| improve this answer | |
  • 1
    Aaa! This is the first thing that I've tried that works! However, I don't see either the wireless or the accessibility indicators present, both of which I want to hide. Would you happen to know where these are? – fouric May 13 '15 at 2:37
  • I confirm that, network indicator which is created by nm-applet and I'm not sure about accessibility indicator. – user.dz May 15 '15 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.