0

I recently tried to install the latest version of Ubuntu on my computer, substituting Windows 7. The installation ran smoothly, but now when I try to boot the system I receive this error message:

reboot and select proper boot device or insert boot media in selected boot device and press a key

The only thing I can do is run the live version via USB, which is what I am doing right now. I looked for a solution in some forums and I decided to run boot-info and post the result of the diagnosis here.

  • Is the machine in UEFI mode? Those are the only bootloaders present. – ubfan1 Apr 2 '15 at 16:49
  • Does it work now? If not, could you try boot-repair? – Fabby Apr 6 '15 at 10:58
0

You have no bootloader installed on /dev/sda. The bootloader may have been installed on the EFI partition on /dev/sda1 but this partition seems to be not active. You could try to set the partition active using the cfdisk command in a terminal window. Hint: as the poster of this question pointed out, one must use parted / gparted to edit GPT partitions.

Attention: it turns out in the comments that this answer was completely misleading. If you however need some information about installing Ubuntu on an UEFI enabled system, you may read https://help.ubuntu.com/community/UEFI

|improve this answer|||||
  • This looks like a UEFI machine, so the bootloaders are in the EFI partition, sda1. – ubfan1 Apr 2 '15 at 16:49
  • So what could I do? Should I "toggle bootable flag on current partition"? Sorry but I am not experienced in these kind of things. I currently have only sda1 in the partition list, sda1, should I toggle the "bootable" option? – Brancaleone Apr 2 '15 at 17:07
  • Yes, if the bootable option is not set, then do it. – NetAndif Apr 2 '15 at 17:11
  • But are you sure that this is the right disk as seen on top of the cfdisk window? – NetAndif Apr 2 '15 at 17:14
  • 1
    @Fabby i have edited my answer to show that it was misleading. Hope this is adequate. – NetAndif Apr 6 '15 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.