4

I have a relatively new install of Ubuntu 15.04 beta. Up until yesterday everything was working swimmingly. At some point on 4/1/15, my right shift key stopped working as a shift key and I haven't been able to figure out why. I'm pretty sure that it is software, because in my various tests, I was able to swap the Left & Right shift keys using xmodmap.

What I'm looking to do is to have both shift keys function as shift. Right now I am using the us layout:

$ setxkbmap -print
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"  };
    xkb_compat    { include "complete"  };
    xkb_symbols   { include "pc+us+inet(evdev)+capslock(ctrl_modifier)+terminate(ctrl_alt_bksp)"    };
    xkb_geometry  { include "pc(pc105)" };
};

What I can't seem to figure out is how to make both shift keys work as shift keys. Here is the xev output for the left (properly functioning) shift key:

KeyPress event, serial 36, synthetic NO, window 0x4000001,
    root 0x2ac, subw 0x0, time 58946313, (110,140), root:(140,225),
    state 0x10, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 36, synthetic NO, window 0x4000001,
    root 0x2ac, subw 0x0, time 58946553, (110,140), root:(140,225),
    state 0x11, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

And the xev output for when I press the right shift key.

PropertyNotify event, serial 36, synthetic NO, window 0x4000001,
    atom 0x137 (_NET_WM_STATE), time 59049363, state PropertyNewValue

FocusOut event, serial 36, synthetic NO, window 0x4000001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 36, synthetic NO, window 0x4000001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 36, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
       0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0 

If it matters, I alternate between Gnome and Mate.

Update (a few hours later): I ran setxkbmap -print on my laptop, which is a very similar configuration (Ubuntu Vidid Beta - Gnome Edition; no MATE installed) and on which the shift keys work as expected, and the output looks exactly the same as the other machine. Quite confusing.

Update 4/8/2015: I logged out of Gnome and into MATE, and the problem went away. I didn't file this as an Launchpad bug because I'm 100% sure that it is something that I did somewhere, and I just can't figure out what. I did scour through Lauchpad looking for anything that seemed to be related, and there was nothing. I figure a package update causing this sort of issue would have affected more than just me.

In any case, the question will soon be closed, so I guess I'll never be able to figure it out.

closed as off-topic by user68186, karel, Eric Carvalho, fossfreedom Apr 7 '15 at 6:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – user68186, karel, Eric Carvalho, fossfreedom
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Try reassigning that shift key to the same key again . More info here – Sergiy Kolodyazhnyy Apr 6 '15 at 17:50
  • That was my original intention, assuming that I wouldn't be able to isolate the proper root cause. My issue is that xev isn't giving me anything useful when I depress the key in question, and I'm not sure how to remap it without the keycode. – Kirk Apr 6 '15 at 19:28
  • Have you tried another keyboard ? Maybe that key is just failing – Sergiy Kolodyazhnyy Apr 6 '15 at 19:34
  • I have, and the problem is isolated to this keyboard. However I was able to swap left & right SHIFT using xmodmap, so I think it is a software issue, and not a hardware problem. – Kirk Apr 6 '15 at 19:45
  • Typo up there. The problem is not isolated to this keyboard. – Kirk Apr 6 '15 at 19:50
1

In ubuntu open keyboard preferences >> Accessibilty

Then under sticky keys check the option Simulate Simultaneous Keypreses - and uncheck the option disabled sticky keys if two keys are pressed together.

Please let me know if this work for you.

  • 1
    I'm using Gnome, so the prefs aren't quite layed out as you describe, but I see this in the accessibility settings: imgur.com/cpBWw9a. As you can see the sticky keys are disabled. I did discover that if I enable it, I can double tap the right shift key to get it to shift. Otherwise it is the same. – Kirk Apr 6 '15 at 14:35
  • I did same, enabled and then disabled sticky keys and its back to normal. Thanks. – amit_kumar Jul 6 '16 at 17:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.