1

I am so new to ubuntu that I haven't even been able to get it to install.
I downloaded ubuntu from the main page, burned it to a disk, have it pop up with rEFIt,and get three options:

  • Book EFI\book\boot64x.efi
  • Boot EFI\boot\grubx64.efi
  • Boot Legacy OS.

These lead to options to try ubuntu, install, etc.
When I click try ubuntu, it goes to a black screen with an error: i8042: No controller found.

*I've also tried to load it via USB, with the same results.

1

I would vote up the previous answer but my "reputation" isn't high enough. What worked for me, on a MacBookPro5,2 (2009 17") was simply to append "nomodeset" in front of "quiet". So the line will end with something like: nomodeset quiet splash -- Hope this helps someone else with an ageing (but still useful!) MacBook Pro.

0

After much searching, this is what worked: when try ubuntu was highlighted, I pressed e and replaced the value: quiet splash with this: "i8042.nomux=1 i8042.reset nomodeset"

0

This is normal.

MacBooks have no i8042 controller (i.e. legacy keyboard controller).

If you are getting no keyboard function in grub, though, that is not normal. That means the fallback of USB-HID or (U)EFI keyboard is not working. In this case you need to add either the USB-HID or (U)EFI keyboard module for it.

If you have OS X installed with boot camp (I recommend installing a stripped copy of OS X on macs simply because it's needed for some firmware updates), you can use bootcamp instead of multiboot in order to provide proper USB Legacy emulation for keyboards to work around this problem. This will also let you use the more reliable legacy BIOS version of GRUB. (While EFI Grub is better than it used to be, it's still far from perfect.)

0

The error code simply means that a device that was present during the installation is no longer connected. For me this was the USB CD drive. Once reconnected it boots without an error.

Doh!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.