0

I have got a PPA on LaunchPad and a pack which depends on gawk (>= 1:4.1.1+dfsg-1) (this is set in the control file). But when uploading the .change file to LaunchPad with dput I get this error:

Dependency wait on lgw01-31

So why is the build failing when it doesn't for any of my other packages of this project? And how can I fix it?

This is the version for Trusty, the versions for Utopic and Vivid build fine. And this is the page with the error message on it: https://launchpad.net/~secretiveppc/+archive/ubuntu/anti-sr/+build/7126328

2
  • Can you give us a link to the page? We might be able to better determine what's going on if we can view the buildlog. Also "lgw01-31" is the name of the machine that attempted to build the package. Apr 1, 2015 at 19:35
  • @NathanOsman: Ok, I have added the information to my question which you requested.
    – user364819
    Apr 1, 2015 at 20:31

1 Answer 1

1

The problem is that you are attempting to build the package for Trusty (Ubuntu 14.04), but your control file requires a newer version of gawk than is currently available for Trusty:

  • the latest version of gawk available for Trusty is 1:4.0.1+dfsg-2.1ubuntu2
  • your control file is requesting a version >= 1:4.1.1+dfsg-1

The solution is to either change your control file to require an earlier version (assuming you aren't depending on a feature introduced in a later version) or backport the newer gawk version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy