1

Installed Ubuntu 14.04 LTS. Monitor does not come on after ubuntu boots. I get a blank screen. Sometimes the screen comes on but the mouse and keyboard do not.

I installed the AMD drivers for the GPU but the issue persists.

If the mouse and keyboard come up, eventually the screen MAY turn on.

If the laptop comes up correctly, mouse, keyboard and screen working... if I suspend it, the screen will not come back. I know the OS is there because I can hear the Ubuntu start up sound.

When the mouse and keyboard do not respond, the power button does work. Upon pressing it, the log off | restart | shutdown menu comes up.

  • Model: Toshiba Satellite C875D Laptop
  • OS: Ubuntu Desktop 64x 14.04
  • Processor: AMD A6-4400M APU with Radeon(tm) HD Graphics : 1400.00MHz
  • AMD A6-4400M APU with Radeon(tm) HD Graphics : 1400.00MHz
  • RAM: 4GB
  • Touchpad: SynPS/2 Synaptics TouchPad
  • Keyboard: AT Translated Set 2 keyboard
  • BIOS: InsydeH2O Version 1.20
1

This thread on Ubuntu Forums helped me.

I also switched to using the fglrx drivers instead of the open source drivers. I am not sure that this is needed but I did it before modifying the GRUB configuration file as below (and as per the mentioned post).

Passing two kernel boot parameters i8942.nomux and i8042.reset gets rid of the problem.

To be able to get Ubuntu to load I had to start the laptop and press f8 to get to the GRUB menu, then press e to edit and go down to the line with ro (second to last) and add the i8042.nomux i8042.reset parameters there it, then press f10 to boot. You only have to do this once.

After booting, to set the parameters permanently, edit the file /etc/default/grub, for example using

sudo nano /etc/default/grub

Find the line that starts

GRUB_CMDLINE_LINUX_DEFAULT=

and add the two extra parameters so that after your changes it looks something like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8942.nomux i8042.reset"

Save and exit, then run

sudo update-grub

to make the changes effective, then reboot.

After installing the flgrx drivers, I think the monitor worked as expected. After the boot settings, everything else worked as expected. Even the suspend feature works now.

One more thing - in the BIOS of the laptop I set the display to LCD only as per another forum thread. Again not sure it is necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.