0

I just got an Asus x205ta a couple of weeks ago, and I currently encounter some problems with the installation of Xubuntu (via a live USB).

After succeeding in getting the grub menu with the Xubuntu installation options, I managed to install it successfully, and after rebooting, I could chose Ubuntu amongst the boot options. I changed it to the first place, but after rebooting, the only thing that I get is the grub menu with installation options.

I have repeated this process at least 4 times, and I got the same installation menu.

I've just noticed the lack of the file vmlinuz-13.06.0-23-generic in the boot directory, Maybe this is the problem ?

Had anybody encountered the same problem ? What can I do to fix the problem ?

  • Please write in an answer, how did you solved the problem. – A.B. Apr 24 '15 at 14:59
1

I solved the problem

  1. I created a 14.10 hotkey, and I copied a bootia32.efi file in the EFI/BOOT directory.
  2. After the installation was complete, I could only access the Grub menu. I hit c, and marked in the command line (autocompleted by hitting tab, so I do not remember the exact versions):

    linux (hd1,gpt2)/boot/vmlinuz-3.16-24-generic root=/dev/mmcblk0p2 reboot=force,pci
    initrd (hd1,gpt2)/boot/initrd.img-3.16-24-generic
    boot
    
  3. To fix wireless issues: kernel must be upgraded to version 4.00 at least, so I manually downloaded the new kernel images and installed them (there are three files)

  4. Reboot and prompt in the grub edit menu the same code as in 2., but with the new kernel's name. The wireless works perfect with kernel 4.0 (I had solve the problem with the WiFi card before installing grub, because my USB WiFi adapter - NeatGear WNA1000M - wasn't recognized).
  5. After that, I followed this guide from the grub installation Qouting it...

After the OS boots open a terminal and type sudo bash then type the following:

Install deps for task (type the line below and hit Enter):

apt-get install git bison libopts25 libselinux1-dev autogen m4 autoconf help2man libopts25-dev flex libfont-freetype-perl automake autotools-dev libfreetype6-dev texinfo

Clone repo (type the line below and hit Enter):

git clone git://git.savannah.gnu.org/grub.git

Compile (type the line below and hit Enter):

cd grub
/autogen.sh 
./configure --with-platform=efi --target=i386 --program-prefix="" 
make
cd grub-core
mkdir -p /usr/local/share/locale
../grub-install -d . --efi-directory /boot/efi/ --target=i386
cd /boot/efi/EFI
cp grub/grubia32.efi ubuntu

And then reboot, and that's it. Good luck!

Installation of drivers for Edimax (EW-7811Un RTL8188CUS)

First finish other configurations desired (ie apt-get update/upgrade, etc).

sudo apt-get install linux-headers-generic build-essential dkms git
git clone https://github.com/pvaret/rtl8192cu-fixes.git
sudo dkms add ./rtl8192cu-fixes
sudo dkms install 8192cu/1.9
sudo depmod -a

edit /etc/modprobe.d/blacklist.conf and add the following at the bottom of the file:

blacklist rtl8192cu
blacklist rtl8192c_common
blacklist rtlwifi

Battery monitor is available with the 4.0 kernel, however, the sound card is not recognized yet unfortunately... And Bluetooth does not work, either. If anyone has a suggestion to fix this issue, I will be very grateful!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.