0

I have a laptop, Dell N5110, with nvidia 525m. I installed nvidia-331 driver which can be found in Ubuntu repo.

When I connect my hdmi all screens are randomly stretched and very chaotic. Some parts of the laptop screen are found in DVI screen and part in HDMI screen. Screens are overlapping, but when I separate them in arandr, after applying all changes it's still unusable.

I looked in xrandr --query and noticed that when all three screens are connected vga1 is shown as disconnected and strange virtual connected.

A similar situation occurs when there is only hdmi and laptop screen.

So basically Nvidia is not working correctly with HDMI port.

how the screen looks

Additionally there is an issue with stretching. Because when I stretch to anything to full size it goes on both screens.

I checked Xorg.conf and it looks like this:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "intel"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "SNA"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection

Shouldn't there be more info about all screens? Or maybe there is a specific file where I can configure nvidia and add some static values?

4
  • Have you tried it with "nvidia-settings"?
    – A.B.
    Mar 31, 2015 at 15:53
  • Till now, i didn't try but in Xserver information says that i have screens:1 and is named as(Display name pcname:0). and when i click on Xscreen 0 information it's dimension is 2390x768
    – rudis
    Mar 31, 2015 at 17:23
  • In my memory, there is an option in "nvidia-settings", as the two monitors are used.
    – A.B.
    Mar 31, 2015 at 17:28
  • i looked through every menu part in nvidia-settings and didn't notice such option ;(.
    – rudis
    Mar 31, 2015 at 18:03

1 Answer 1

1

So after some experiments and with a little luck I found out that I had to regenerate my xorg.conf file using the command: sudo nvidia-xconfig. After that restart lightdm and that's it ;)

Additionally, in Display Settings (not nvidia-settings) you will probably have to choose to align all by laptop screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.