1

Fresh install of Ubuntu 14.04.1 LTS (updates bring it up to 14.04.2 LTS)

USB 3.0 flash drive (Corsair 64 GB Survivor Stealth and Silicon Power 64G M70); both show slowness prior to loading "libccid". Both are fast for READ only after installing libccid (WRITE is still slow even though SuperSpeed was finally recognized in the /var/log/syslog; prior to installing libccid "high-speed" was all it would show)

The Corsair 64GB Survivor Stealth seems to use a Etron controller (not Phison like I was initially thinking if that matters to anyone). Not sure what controller the Marvel M70 uses, but I think it might be Phison)

I've gotten consistently 45 MB / sec read speed with the Corsair Survivor Stealth when it was recognizing as high-speed NOT SuperSpeed. (Windows 7 shows 200 MB/sec read and 147 MB / sec write for the Corsair).

After installing libccid :

After running: sudo apt-get install libccid and rebooting, I was able to get about 200 MB / sec READ on both drives. However, the WRITE speed is horrible... around 15 MB/sec for the Corsair Survivor Stealth and around 5 MB/sec for the Silicon Power Marvel M70.

Side Note: a Transcend JetFlash 790 worked fine with a fresh install with expected USB 3.0 speeds and proper recognition of "SuperSpeed" unlike the other devices until I installed "libccid" (both read and write were fine with the Transcend prior to installing libccid).

Firstly, I'm not entirely sure why I needed libccid as it seemed to have something to do with smart card readers etc... but, I tried it anyway and seemed to finally get "SuperSpeed" to show up for the Survivor Stealth and Marvel M70.

Secondly, is there another way to get this thing working with USB 3.0 speeds for both read and write And is "libccid" potentially considered a bad idea for some reason; i.e. I'd rather not have data corruption and deal with USB 2.0 speeds if it really must come to that... ?

EDIT: After many subsequent tests, I'm starting to think it was merely coincidental that suddenly the USB 3.0 "SuperSpeed" recognition in /var/log/syslog right after I installed "libccid". My proof is I did a full fresh installation and did not install libccid; after about 20 USB drive connections it finally reported SuperSpeed (and gave very fast READ speed, but slow WRITE speeds as metioned above) ... but again, I did not install libccid to achieve this.

I'm still trying to figure out how to reliably get these drives to reliably connect at USB 3.0 and give expected read and write performance speeds.

  • That also sounds like the basis for a good bug report, which should be filed on launchpad.net. – Jo-Erlend Schinstad Apr 2 '15 at 1:57
  • I have this issue. I have a phillips Flash drive with a usb 3 port, tested in linux mint, read speed is 90MB/s and write speed is 5MB/s – Morteza Ziaeemehr Jan 27 '16 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.