4

I'm running a system with Ubuntu 14.04 LTS, and about a month ago, I started getting a pop-up message when I login asking if I would like to proceed. The only option is ok, and when I click it, everything boots up normally. It has become annoying and it also resets the to the default wallpaper when on the login screen (not the wallpaper that is on my desktop). I've tried modifying everything in my .profile as suggested here and tried turning off some startup applications, but nothing seems to work. Thanks in advance!

Edit to add information: when source /home/bryce/.bashrcis run, this error appears: E: Command line option 'r' [from -r] is not known.. For startup applications I have xbacklight, devilspie, easystroke, dropbox, bumblebee, nvidia settings, and indicator application. Also, this problem only occurs after a complete logout/reboot. When the account is just locked, everything works as it should.

Edit 2: Here's my .bashrc: .bashrc (sorry, I forgot how to use code blocks)

2

From what I can tell this dialog appears when there is an error in one of your shell configuration files. The fact that there is an error in your .bashrc seems to confirm this. After looking through the file the only suspicious thing I can find is in line 4:

archey  

I've never heard of an application named archey but it is the only thing that stands out, the rest of the file looks quite stock. Since you said besides this everything seemed to be working fine lets just send the error to /dev/null and bypass the problem. Change the line so that it reads:

archey 2> /dev/null  

This will redirect all errors into the emptiness of /dev/null. This technically just bypasses the issue (archey is returning errors) but as you say everything is working as expected I see no problem with that.

Your wallpaper issue I would consider unrelated (unless archey has something to do with wallpapers). This answer suggests several possible reasons:

  • Your image file is not read only. This should only be an issue if you're using a non stock wallpaper.

  • The feature got turned off. In this case just turn it back on by running:

    gsettings reset com.canonical.unity-greeter draw-user-backgrounds
    

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.