2

Ubuntu 14.04 desktop, 64-bit

I came in to work this morning and noticed that the clock on my system was off by approximately 3 minutes, as compared to the clock on my phone. That seems odd, since my system is on 24/7 and should be keeping the time synced with ntp.ubuntu.com, right? And I've never noticed this problem before.

In the system configuration, the "Time & Date" settings are set to set the time automatically from the internet.

So I started digging...

First I used ntpdate to update the time. This worked, but a few minutes later the time was incorrect again - by approximate -217 seconds.

Next, I installed ntpd, hoping that continuous updating would solve the problem. I reset the date using ntpdate and started the ntpd service. No luck - a few minutes later, the time was off, again by approximately -217 seconds.

The offset of -217 seconds seems pretty consistent - ie. it doesn't appear to drift once it hits that difference. This suggest to me that there's something on my system resetting the time periodically, and because the change is too large, ntpd will not adjust it.

After some more experimenting, I have determined that whatever is resetting my clock is doing it approximately every 5 minutes. I've looking in my crontab and the crontab for root, as well as the system-wide cron files.

A couple of additional details:

  1. I have joined by system to a Windows domain using Likewise Open.

  2. There was a major change to our network over the weekend - we switched from one connection to a different (faster) connection. However, I appear to be the only one experiencing this issue (amongst about 30 Windows PCs, Ubuntu PCs, and Macs).

So, a couple of questions:

  • What could be doing this?
  • If a scheduled job is not in my cron files, where could it be?
  • 1
    You could try running it offline to see if it is the hardware clock - setting the time manually or with ntpdate, disabling the existing time update (using the thing in settings might work) and then having a cron run every so often to update it could work – Wilf Mar 30 '15 at 20:54
  • I did wonder about the hardware clock, but it's odd that it always wants to jump ahead the same amount, at the same interval. – Kryten Mar 30 '15 at 21:21
2

It could be leading to the solution that a domain member should not have more than 5 minutes clock skew. See http://download1.beyondtrust.com/Technical-Support/Downloads/files/pbiso/Manuals/likewise-open-54-guide.html#id2944830 I suggest the settings of Likewise make sure that this time difference cannot occur. A windows domain member would normally sync with the PDC but it could be possible that your client syncs with an out-of-sync DC. Just a thought.

  • Looks like this was it. Checked our primary domain controller & discovered that the time service was not updating properly. It looks like it has not been updated in some time, and the time was slowly drifting farther & farther away from the "real" time. I think I've fixed it by updating the primary domain controller - I'm gonna have to check it in a little while & see if I can figure out if it's updating properly. – Kryten Mar 30 '15 at 22:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.