I am trying to install pysoy and at the stage of configuration using

./waf configure

it gives an error as seen below

Checking for 'gee-0.8' >= 0.8.0          : not found

The configuration failed

(complete log in /home/mylap/Documents/coding/pysoy/libsoy/build/config.log)

I think this needs libgee needs to be installed..

My attempt to install libgee:

  1. downloaded libgee-0.11.4 from net
  2. set workspace to that directory and i ran ./configure
  3. ./configure executed succesfully
  4. ran make command and encountered this error :

mylap@mylap-Inspiron-N5110:~/libgee-0.11.0$ make
make  all-recursive
make[1]: Entering directory `/home/mylap/libgee-0.11.0'
Making all in gee
make[2]: Entering directory `/home/mylap/libgee-0.11.0/gee'
make[2]: Leaving directory `/home/mylap/libgee-0.11.0/gee'
Making all in tests
make[2]: Entering directory `/home/mylap/libgee-0.11.0/tests'
  CCLD     tests
../gee/.libs/libgee-0.8.so: error: undefined reference to 'g_get_num_processors'
collect2: ld returned 1 exit status
make[2]: *** [tests] Error 1
make[2]: Leaving directory `/home/mylap/libgee-0.11.0/tests'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/mylap/libgee-0.11.0'
make: *** [all] Error

  1. I couldn't find answer for " undefined reference to g_get_num_processors Please help

(Also, can someone add tag pysoy to this question. I don't have the privilege to make new tags..)

  • per my comment below, which Ubuntu are you on/using? – Thomas Ward Apr 2 '15 at 20:03

Please install first these packages:


You can install them with this command:

sudo apt-get install libgee-0.8-2 libgee-0.8-dev

Or with this other:

sudo apt-get install libgee-0.8*
| improve this answer | |
  • I tried..got this error E: Unable to locate package libgee-0.8-2 E: Couldn't find any package by regex 'libgee-0.8-2' E: Unable to locate package libgee-0.8-dev E: Couldn't find any package by regex 'libgee-0.8-dev' – Raje Apr 2 '15 at 13:10
  • In my computer with Ubuntu 14.04 works perfectly. Did you ran it copying/pasting or typing? However, I edited my post, try the second command. – 0x2b3bfa0 Apr 2 '15 at 19:39
  • @Raje Which version of Ubuntu are you using? libgee-0.8 and its packages are only available in Trusty and later and unless you are on Ubuntu Trusty or later you won't be able to easily get those dependencies. – Thomas Ward Apr 2 '15 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.