1

When I boot Ubuntu it loads and shows only the desktop background. I have a black cross cursor and can right click to show the expected context menu for the desktop.

I can use Ctrl+Alt+F1 to get a terminalF1toF6 (tty1 to tty6) from which I have tried a lot of things suggested to others with similar issues on here.

I tried the basic sudo apt-get update and sudo apt-get upgrade which didn't help. I tried restarting lightdm. Updated nvidia drivers. Nothing made a difference.

One post said the issue was to do with the ccsm unity plugin being disabled. I managed to get that program to run and the plugin was disabled but enabling it has made no difference.

One suggested that unity needed reinstalling so I ran sudo apt-get install --reinstall unity. It reinstalled but didn't fix the problem.

Another said to install GNOME then switch back to unity which didn't work (though I could load gnome without any problems). I also ran a few commands which were supposed to set the defaults and reset settings though I can't remember what they were exactly. As you may have guessed those had no effect too.

Anyone have any ideas? I would just reinstall Ubuntu from usb but I have no way to get it onto a USB to do so.

Edit: The linked duplicate answer is one I had already tried and found didn't solve my issue.

1

I ran into the same problem using MATE 1.8 under Ubuntu 14.04 and after hours i ended up installing Cinnamon (which i'm more than happy now with, btw.), to get a working desktop to find out what's going wrong.

The solution was to disable all the autostart programs from MATE inside my user profile. I've moved all .desktop files out of ~/.config/autostart/ and then been able to login to MATE again.

I'm 99% sure your problem will be fixed by disabling your autostart items.

  • Deleting the compiz.desktop file seems to have worked. :D Just gotta redo all my settings I assume. – James Coyle Mar 30 '15 at 23:08
1

For the Desktop Issue use these commands,

sudo apt-get update
sudo apt-get remove ubuntu-desktop unity -y
sudo apt-get purge ubuntu-desktop unity -y
sudo apt-get install --no-install-recommends ubuntu-desktop -y
sudo apt-get upgrade -y 
sudo apt-get dist-upgrade -y
sudo apt-get autoclean -y
sudo reboot

As for your USB, go on someone else's computer, Install UNetBootIN and Burn the ISO

  • That hasn't worked for me. :/ – James Coyle Mar 30 '15 at 23:04
  • Install Cinnamon then..... – DeOxyRibose Acid Mar 31 '15 at 13:12
  • He didn't need to install Cinnamon. Just deleted .compiz.desktop file in ~/config/autostart folder. From my comment, you may have thinked that my solution was to install another Window Manager. This was only to be able to have a desktop which made it easier to apply the fix. I'm using XFCE and Compiz meanwhile, btw. :-) – NetAndif May 24 '15 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.