1

community I have since a clean ubuntu 14.04.2 install and two weeks searching the following Problem.

System Specs:

  • OS: Ubuntu 14.04.02
  • Kernels:
  • 3.16.0-30-generic (does not boot)
  • 3.16.0-31-generic (boots but with black screen, the log screen sounds as if the log screen is there)
  • 3.16.0-33-generic (same as 3.16.0-31)
  • Graphic Card: Nvidia GTX 860M
  • Graphic driver: nvidia-346.47

I installed the driver using the ppa:xorg-edgers/ppa. Ubuntu booted normally with the GUI. Without the xorg-edgers repository the "additional drivers" program does not recognized, that the laptop has a GTX 860M card installed. After the installation the "NVIDIA-Settings" program showed the correct graphic card, but the "additional drivers" program showed only that an Unknown NVIDIA device is present and different NVIDIA drivers 340, 346, 349 and nouveau to choose from.

Then I tried to install CUDA 7.0 using the .deb package. The installation was not possible, because apt-get gave me depencies problems as described here:

https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1428972 (comments #9)

I used sudo apt-get install libglew-dev libcheese7 libcheese-gtk23 libclutter-gst-2.0-0 libcogl15 libclutter-gtk-1.0-0 libclutter-1.0-0 to resolve the depencie problems but since then when I boot I get a black screen as described in the System Specs List. I can access the virtual consoles (tty1- tty6) and the outputs of prime-select query is NVIDIA, nvidia-detector is none.

I do not understand, why the "additional drivers" program does not recognized the graphic card I have Even though I followed the instruction described here:

How do I use Nvidia GTX 860M with 14.04?.

And furthermore why I get the unmet dependencies problems. Those problems don't let me install freeglut3-dev. How can I manage to boot normally?

Update 2015-04-15

Hi, I performed a fresh install of Ubuntu 14.04.1. The “Additional Drivers” section didn’t recognized my nvidia (GTX 860M) graphics card at all. I added the xorg-edgers and installed the nvidia-356.59 driver and got the black screen problem. I apply the solution proposed here and worked. Then I proceeded to apply all the following Ubuntu updates and updated until 14.04.2. I was happy that everything was running well.

Then I proceeded to install CUDA 7.0 and now I have the following problem: Sometimes my laptop hangs on boot: the last line of the booting process before hanging reads: ‘Starting ACPI daemon [OK]’

After that I only can power off the laptop pressing the power button. Using the nomodeset boot parameter allows me to boot with the nvidia driver selected, without freeze, but I get the login screen and after logging in I only see my desktop background and the mouse pointer. Usint Alt + F2 or Ctrl + Alt + T does nothing (only the tty1-6 work). From there switching to intel drivers using sudo prime-select intel fails.

When the laptop does not hangs I get again a black screen. I can use the others ttys and using prime-select query outputs nvidia. If I wait until the “screen saver” is activated then the X Server works. Does anyone else have the boot problem as described here?

  • possible duplicate of My computer boots to a black screen, what options do I have to fix it? – JoKeR Mar 30 '15 at 21:09
  • take a look here askubuntu.com/questions/601894/… – JoKeR Mar 30 '15 at 21:11
  • I happen to be in the same situation with the same hardware/software configurations with the OP. I can say that I've tried the links posted above and none of them worked, I ended up with nouveau drivers. Would be interesting to see if there is another solution. – SimpleMan Mar 30 '15 at 22:24
  • Thanks @JoKeR for the links. Sadly I have already come across with them an used the proposed solutions without success. – wp11 Mar 31 '15 at 11:04
  • if this worked with gtx840m obviously you're going some way or some where wrong. I have nvidia and I tried all the possible solutions even crashed it myself to low-graphic mode or black screen each of them require the specific step in comment #2 there's a link how to install nvidia with a complete tutorial on nvidia written by me I used it on 12.04LTS and 14.04LTS and it works. Though Bumblebee mostly works always on hybrid graphics. – JoKeR Mar 31 '15 at 11:18
3

I have had the same problem for a long time and I think I have found the solution. I have Ubuntu 14.04 LTS, my graphic card is Nvidia GTX 860M. The problem of black screen or freezing on the splash screen is related to nvidia-drivers and openGL libraries that cuda installs alongside.

So here what happens:

  1. First you install the graphic card driver which has 3xx.yy version. For me it was 346.82 (proprietary, tested). Usually, after this step you should not have OS loading problems.
  2. Next when you take the .deb package which has all dependencies. This dependency is really huge and long, so nobody bothers to look what actually it tries to install. What it does is it installs nvidia drivers again. For me it was the same version 346. Here the subtle difference comes up. It installs 346.00 version and overrides previous installation of the 346.82. Usually, xxx.something means that it was patched several times and bugs were fixed. Cuda installation rolls back to initial 346.00 where a lot of bugs exist.
  3. Alongside with Nvidia drivers it also installs lib-mesa which overrides the openGL files installed by previous Nvidia driver installation.

This problem is described here: http://developer.download.nvidia.com/compute/cuda/7_0/Prod/doc/CUDA_Getting_Started_Linux.pdf in the section "RUNFILE INSTALLATION" subsection 4.2. Here what it says:

"Installing Mesa may overwrite the /usr/lib/libGL.so that was previously installed by the NVIDIA driver, so a reinstallation of the NVIDIA driver might be required after installing these libraries."

This made me dig into that direction and find out the problem causing all this crap with freezing OS.

THE BOTTOM LINE

Whenever you install cuda either by *.deb or *.run files, make sure you apply correct nvidia driver before restarting your PC. After this OS should load properly + you can use nvcc compiler to compile and run cuda programs. (g++ installation may be required separately, depends how you install cuda).

For me it worked well. Hope it will help you too.

Additional steps:

If you have discrepancy between Nsight versions that you run from terminal and application launcher. Here are the steps to fix this:

ls ~/.local/share/

in my case I have got

chrome-aohghmighlieiainnegkcijnfilokake-Default.desktop
chrome-apdfllckaahabafndbhieahigkjlhalf-Default.desktop
chrome-blpcfgokakmgnkcojhhkbfbldkacnbeo-Default.desktop
chrome-coobgpohoikkiipiblmjeljniedjpjpf-Default.desktop
chrome-pdabfienifkbhoihedcgeogidfmibmhp-Default.desktop
chrome-pjkljhegncpnkpknbcohdijeoejaedia-Default.desktop
jetbrains-idea.desktop
mimeapps.list
**nsight.desktop**
nvvp.desktop
**org_eclipse_equinox_launcher_1_3_0_v20120522-1813_jar.desktop**

Make sure that Exec=/usr/local/cuda/bin/nsight TryExec=/usr/local/cuda/bin/nsight point to the cuda installation path. Also check if org_eclipse** is not used instead of nsight.

| improve this answer | |
  • Can you elaborate how you "make sure you apply correct nvidia driver before restarting your PC" ? – kmace Jan 25 '17 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.