I am connecting from my Windows 7 machine to my Lubuntu 14.04 server using TightVNC. Everything is working as expected except the remote mouse cursor only displays as an "X".

screenshot

My ./vnc/xstartup file is configured as follows:

#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
autocutsel -fork
lxsession -s Lubuntu -e LXDE

and to set up TightVNC on the server, I installed the following packages:

  • lubuntu-desktop
  • tightvncserver
  • autocutsel

Do I need to install a package to get the remote mouse cursor to show up correcting when using TightVNC? Do I need to add a command to my xstartup file?

up vote 13 down vote accepted

After researching into each command used in my xstartup file and the options available, I found the solution to be adding the following parameters to xsetroot:

-cursor_name left_ptr

So, my xstartup file now looks like this:

#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey -cursor_name left_ptr
autocutsel -fork
lxsession -s Lubuntu -e LXDE

screenshot

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.