3

I need to do something with Ruby on Rails, so I have followed this guide to set up my development environment.

I used the RVM method to install Ruby, then I install Rails as shows in the guide. I run both ruby -v and rails -v and they give me the expected output, I do my stuff using rails and everything is ok.

Problem is that when I restart my machine nor Ruby or Rails is installed, I have to install them back everytime I restart. Do you know what could be the reason?

6

Are you sure that its not just RVM not being started ?

Check .rvm/scripts/rvm exists in your home directory.

If it does, then its probably not being started, check in your .bashrc for lines below.
If they are not there you need to add the calls to initialise RVM in your .bashrc by running the following command:

echo '[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm"' >> ~/.bashrc

Based on instructions from: http://sirupsen.com/get-started-right-with-rvm/

  • 1
    Thanks a lot man, .rvm/scripts/rvm exits and I added this command at the end of .bashrc and it solved my problem. Have a nice day. – Castiblanco Mar 30 '15 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.