4

I'm facing a strange issue on my BQ Aquaris E45 Ubuntu edition, i'm on Ubuntu 14.10.

While using every app or webapp, needing location it fails. my gps is on and detects my position. I also have checked use both gps and wifi to determine location and remains failing.

I have downloaded the app Location Service Test, and if gave me the error 'NoPositioningMethod'.

Did I missconfigured something or should install a package?

Any help is highly appreciated.

2
  • This could be a known bug:- bugs.launchpad.net/ubuntu/+source/location-service/+bug/1426307
    – popey
    Mar 30 '15 at 12:59
  • 1
    On my BQ Aquaris E4.5 the GPS does work, but no matter which app I use (Here maps, BikeMap, Cachemere, ...) The GPS works for a while, then it stops updating the position, when I restart the app (really close, then start again) the GPS works again for a few seconds or mostly a few minutes. Apr 8 '15 at 19:53
1

Please note that standalone GPS positioning is quite slow in acquiring a fix. That is, without any additional help, the time from requesting a position until the first actual fix is delivered may very well take ~20 minutes depending on satellite visibility.

That being said, we have enabled multiple ways of speeding up location fixes. All of them require a non-roaming data connection, e.g., a WiFi connection or a mobile data connection.

2
  • Thank you for the answer, i'm currently on roaming data connection i'll give your answer a try on my wifi connection. Are you aware of a fix regarding the delay of fixing a satellite ?
    – jamel
    Mar 30 '15 at 13:08
  • Long "time to first fix" periods in GPS are unfortunately nothing we can fix but have to live with. We mitigate the situation in the image today by providing network-based positioning capabilities as pointer out before. Mar 30 '15 at 13:37
1

Did you accept Here terms and conditions when running the wizard? If you didn't, you can still do it later: - Check that in the GPS indicator you have both enabled. - In Settings -> Security and Privacy, go to the location access setting (my phone is in Spanish so I'm not 100% how it's called in English). If you have selected "only GPS", do change to GPS,wifi and data connection (2nd option). - After this, you'll need a reboot to have it working. I tried with the app location tester and it worked :D

2
  • thanks for the answer, yes i have accepted here terms and reboot and there are still some issues.
    – jamel
    Apr 13 '15 at 23:09
  • It works for me, google nexus 4, 14.09 rtm
    – evergreen
    May 7 '15 at 16:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.