5

Here is how the clock appears in my gnome shell:

gnome Clock

Even though I'm using the Arabic language, this is not how the clock should be displayed.

Previously, it worked well but now I don't know what happened.

Note: the clock still works well (currently: 9:33) but the only problem is that it appears inverted as you see in the picture above. Also, the date is correct and written in the correct format.

I'm using Ubuntu 14.04 LTS, gnome shell version 3.10.4. According to the settings, Ubuntu identifies the Arabic language (Lebanon) correctly:

Examples

  • Is the arabic one displaying right to left (as it should be)? – heemayl Mar 29 '15 at 18:55
  • 1
    @heemayl in arabic typing is from right to left but the clock (and other numbers) should appear from left to right. – Mhmd Mar 29 '15 at 18:57
  • @heemayl yes it is. – Mhmd Mar 29 '15 at 18:58
  • 1
    Please can you provide more information regarding your installation. What distribution are using? What version of Gnome Shell is being used? What Arabic language are you using? Thanks – octoquad Apr 3 '15 at 8:59
  • 2
    @Mhmd,thanks. I have done a bit of testing it seems clutter is rendering the text ltr for everything in the clock, which seems wrong to me. This might be a bug, but let me do some more testing with the GNOME main and staging PPA's. Additionally, some one else reported a similiar problem for a different language five months ago: askubuntu.com/questions/541865/… – octoquad Apr 4 '15 at 9:24
4
+50

This looks like a bug. If I enable seconds to be displayed with the hours and minutes using Tweak Tool, the hours and minutes are correct, but the seconds are now placed on the left (using 20:45:18 - H:M:S).

Screen shot of clock taken at 20:45:18

I would definitely file a bug report here: https://bugs.launchpad.net/ubuntu-gnome/+filebug

Since this is trivial to reproduce, I will triage it for you so a developer who knows a bit more about this can take a look.

There was one similar, but unrelated bug report I found upstream: Bug 743821 - change in the places of time slots on Arabic desktop.

Best guess at this point is that the time is being split by the colon, and the last piece is moved to the beginning and in your case, the minutes are moved to the beginning:

1 -> 20

2 -> 45

3 -> 18

Becomes

1 -> 18 (3)

2 -> 20 (1)

3 -> 45 (2)

And the really interesting thing is, the lock screen does not have this problem.

Lock screen awesomeness

| improve this answer | |
3
  1. Install the package dconf-tools from the Ubuntu repositories(available on Software centre). This installs the dconf-editor which is needed for changing the configuration.
  2. Open dconf editor from the Dash or dconf-editor from the shell. In the editor, navigate to com.canonical.indicator.datetime.
  3. Change the time-format field to custom.
  4. In the custom-time-format field, change the value to the desired format. The format can include both the date and time specifiers. This format uses the same specifiers as that of the C standard library function strftime().

eg:

%Y-%m-%d %a %H:%M

2015-04-01 Wed 23:45


Alternatively, you can try commands in terminals to so the same as follows:

gsettings set com.canonical.indicator.datetime time-format 'custom'

gsettings set com.canonical.indicator.datetime custom-time-format '%Y-%m-%d %H:%M'
| improve this answer | |
  • sorry, none of the two options are working. it seems that it has no effect at all. – Mhmd Apr 3 '15 at 14:03
  • gnome-shell, not unity – Aurelia Apr 3 '15 at 15:47
  • Since you are on gnome,try extensions.gnome.org/extension/795/format-clock – Dhaval Simaria Apr 3 '15 at 16:44
  • Or try this: Open gconf-editor through terminal. When in the gconf-editor, you need to go to /apps/panel/applets/clock_screen0/prefs and then change the custom_format and format parameters. I haven't tried it personally but this I believe should work. – Dhaval Simaria Apr 3 '15 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.