2

Alright so I've been stumped on this issue for a while now and I'm not sure how to fix it. I'm trying to migrate from Windows 8.1 however when I try to install Ubuntu (or any other OS that supports secure boot) the screen is really blurry during and after the install process. I took a picture of what it's looking like

here

from farther away it looks worse and I can barely make anything out. I'm not sure how to go about solving this issue so any assistance would be greatly appreciated.

Motherboard - ASUS M5A97 R2.0

Graphics Card - NVIDIA GTX 750 Ti

  • Have you tried completing the installation? – Elder Geek Mar 29 '15 at 17:38
  • Yeah I have tried completing the installation and it still looks just as blurry. – imNP Mar 29 '15 at 17:49
4

I had the same issue with my GTX 750 Ti. I was able to resolve it with the following steps:

  1. Add nomodeset to bootloader (How do I set 'nomodeset' after I've already installed Ubuntu?)

  2. Run the following commands in terminal:

    sudo add-apt-repository -y ppa:xorg-edgers/ppa
    sudo apt-get update
    sudo apt-get install nvidia-346
    
  3. Restart the computer

  4. Remove the repository after restart (Thanks @Pilot6 ):

    sudo add-apt-repository -r ppa:xorg-edgers/ppa
    

Step #1 is just to get you into the terminal since everything on the OS is blurry otherwise.

  • 1
    I suggest removing xorg-edgers ppa after drivers install. sudo add-apt-repository -r ppa:xorg-edgers/ppa – Pilot6 May 24 '15 at 22:06
  • Yep, I've made the edit. Thanks @Pilot6 – waynethec May 25 '15 at 19:19
  • 1
    Just for future, you can add repository remove right after install. – Pilot6 May 25 '15 at 20:46
3

It looks to me as if your X installation is running at too low of a resolution. Try this for diagnostics (and maybe to fix it):

  1. Open System Settings.
  2. Select Displays.
  3. Look at the value next to Resolution. Ideally, it will match the maximum resolution of your monitor. If it is, then something else is the cause; but if it's ridiculously low, that confirms my hypothesis.
  4. If the Resolution value is too low, click it and see if there are other options. If you're very lucky, you'll be able to adjust the resolution to something reasonable.

If the resolution is too low but you can't increase it, there are other ways to adjust it, as described in these questions/answers:

There are others along the same lines.

  • I went and looked at my resolution and it's the right size. It said built in display though. Not sure what else I should try here. – imNP Mar 29 '15 at 22:36
  • 1
    Did you install the drivers for the GPU @imNP ? – atreyabain Mar 30 '15 at 7:23
0

I've had the same issue. Installed on multi monitors but disconnecting them after install and reconnecting them so they were redetected fixed the issue.

I now have the issue again on install after messing up my earlier success by trying to update to 15.04.

Back at the installer again. All is blurry. But changed monitors from a Benq which wants to run at 1920x1080 to a 720p TV has given me a readable screen. I know this isn't a perfect answer but it's an answer that works.

0
+25

Boot from the Ubuntu installation media.
Highlight Try Ubuntu without installing.

Press the E key - add nouveau.modeset=0 at the end of the linux line.
Then press the F10 key to boot the Ubuntu Live desktop environment.

After having installed Ubuntu repeat the same on the first system start.
Highlight the Ubuntu entry in the GRUB boot menu, add the parameter.

Boot Ubuntu and install the proprietary NVIDIA drivers ... reboot the OS.
From now on you don't have to modify the Ubuntu menu entry anymore.

0

Try installing this using a basic video driver. When I have my server, sometimes I have to run it using a basic video driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.