6

I have been trying to install Gitlab on a instance of Ubuntu 15.04.

Unfortunately when I run:

sudo gitlab-ctl reconfigure

I get the error message:

STDERR: initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused

How can I proceed...?

2
  • Can the people who left down-votes let me know why...? This was something I spent some time on and I thought it might be useful for others to know about. – Joel B Mar 29 '15 at 17:58
  • Nevermind, I vote you up, I have the same problem, and it seems that developers don't want to fix it for 15.04 is not a LTS version, and I still need a solution. – GutenYe May 3 '15 at 16:06
10

Ubuntu 15.05 no longer uses Upstart. It uses SystemD. GitLab hasn't been updated to check for this at the time of writing.

The rules that deal with this are in /opt/gitlab/embedded/cookbooks/runit/recipes/default.rb

So one can amend the Debian rule:

when "debian"
  case node["platform"]
  when "debian"
    if node["platform_version"] =~ /^8/
      include_recipe "runit::systemd"
    else
      include_recipe "runit::sysvinit"
    end
  else
    include_recipe "runit::upstart"

to

when "debian"
  case node["platform"]
  when "debian"
    if node["platform_version"] =~ /^8/
      include_recipe "runit::systemd"
    else
      include_recipe "runit::sysvinit"
    end
  else
    #include_recipe "runit::upstart"
    include_recipe "runit::systemd"

NB: Yes, I answered my own question as I was stuck on this and wanted to share.

Not the answer you're looking for? Browse other questions tagged or ask your own question.