1

I am able to connect to both wired and wireless networks and able to browse via a browser. So I don't think there's any network issue.

However I cannot run any internet based command from my terminal even a sudo apt-get update command gets stuck showing

`0% [Connecting to 7.1.1.12 (7.1.1.12)] [Connecting to 7.1.1.12 (7.1.1.12)]`

and get stuck there.

I tried doing sudo iptables -F after following another answer but to no good.

Please help me with this.

  1. Output of ping google.com

    PING google.com (216.58.220.14) 56(84) bytes of data.<b>    
    64 bytes from bom05s05-in-f14.1e100.net (216.58.220.14): icmp_seq=1 ttl=58 time=1.91 ms
    64 bytes from bom05s05-in-f14.1e100.net (216.58.220.14): icmp_seq=2 ttl=58 time=2.04 ms
    64 bytes from bom05s05-in-f14.1e100.net (216.58.220.14): icmp_seq=3 ttl=58 time=1.73 ms
    64 bytes from bom05s05-in-f14.1e100.net (216.58.220.14): icmp_seq=4 ttl=58 time=1.75 ms
    
  2. Output of ping 8.8.8.8

    PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
    64 bytes from 8.8.8.8: icmp_seq=1 ttl=59 time=1.62 ms
    64 bytes from 8.8.8.8: icmp_seq=2 ttl=59 time=5.49 ms    
    64 bytes from 8.8.8.8: icmp_seq=3 ttl=59 time=1.39 ms    
    64 bytes from 8.8.8.8: icmp_seq=4 ttl=59 time=1.39 ms    
    64 bytes from 8.8.8.8: icmp_seq=5 ttl=59 time=1.46 ms    
    64 bytes from 8.8.8.8: icmp_seq=6 ttl=59 time=1.44 ms
    
  3. Output of env | grep -i proxy

    http_proxy=http:// 7.1.1.12:3128/
    ftp_proxy=ftp:// 7.1.1.12:3128/
    socks_proxy=socks:// 7.1.1.12:3128/
    https_proxy=https:// 7.1.1.12:3128/
    
  • Are you using a proxy server in your GUI applications that you haven't told the command-line applications about? – Oli Mar 29 '15 at 9:56
  • No proxies in use. The browsers are using the default configurations only. – tejaskhot Mar 29 '15 at 10:02
  • 1
    Are you sure it is supposed to be connecting to US Department of Defence? They don't seem to have any web server on that address, so I am suspecting it isn't legit. Somebody may have been forging some DNS replies. – kasperd Mar 29 '15 at 10:07
  • I am a naive user and have no clue of what's happening to be honest. I haven't changed any settings on my part. Could you tell me how to reset the whole thing ? – tejaskhot Mar 29 '15 at 10:08
  • what are you trying to do? ... maybe "internet based command" is not for naïve users – Skaperen Mar 29 '15 at 10:19
0

In your case, the apt-get command is finding those http_proxy entries and attempting to connect to the internet through them. In this case, it is an IP address belonging to the Department of Defense, and the :3128 is indicating Squid.

Either you do work for the DoD - in which case you should not be posting this information on a public forum, this should be going through your department admin.

Or you accidentally added those entries there. Check your /etc/environment file for those entries and comment them out. If it isn't in /etc/environment, have a look at your ~/.profile file as well; same deal, just comment them out.

0

Ok, i see a space into the URL, just before the IP addresses. Please remove those spaces from those *proxy env variables, and if that doesn't work, please try to unset it.

To set it correctly: export http_proxy=http://7.1.1.12:3128/

To unset it: unset http_proxy

Edit: Just repeat it for all *proxy variables

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.