17

I have recently moved over from SteamOS which is Debian Wheazy. None of the other fixes have not worked, I tried getting steam both through Steam itself and the Ubuntu Center.

  • what version of ubuntu are you using and what "other fixes" have you tried that did not work and please post the output that lists the missing 32-bit libraries so I can look them up for you. – mchid Mar 29 '15 at 3:24
  • For a fresh install of 14.04.2 - you're using the HWE mesa stack & need to install the ..lts-utopic package(s). So sudo apt-get install libgl1-mesa-glx-lts-utopic:i386 should prove useful – doug Mar 29 '15 at 4:04
  • the current hwe stack is for vivid now that utopic is eol. – mchid Aug 22 '15 at 18:00
34

Assuming libc.so.6 is the only one you are missing, open a terminal and execute the following commands to install the missing library (be careful here and do not accept changes unless you are happy with the changes ie may uninstall stuff you want to keep!!):

sudo apt-get update
sudo apt-get install libc6-i386

Please post any errors.

| improve this answer | |
  • 1
    It's hard to tell whether this would have worked for the OP, but I got the same error from Steam on Debian 8, and installing libc6-i386 worked for me. – Beetle Jul 31 '15 at 11:27
  • E: Unable to locate package libc6-i386 – Zenon Feb 14 '18 at 3:57
  • @Zenon What version of Ubuntu are you using? – mchid Feb 18 '18 at 17:34
  • @mchid Ubuntu MATE 16.04 – Zenon Feb 18 '18 at 17:46
  • 1
    @Zenon My friend told me that steam games are usually available online and that you don't usually need to install steam to play the games (I am not sure myself). Also, how did you install steam? Did you use apt-get? The command would be: sudo apt-get update; sudo apt-get install steam or sudo apt-get update; sudo apt-get install steamcmd – mchid Mar 4 '18 at 3:14
2

If like me, mchid answer didn't solved your issue, try making a symlink to libc.so.6 and reinstalling steam from steamcmd:

find /lib -name libc.so.6
ln -s /lib/i386-linux-gnu/libc.so.6 /lib/libc.so.6
mkdir ~/steamcmd2 && cd $_
wget http://media.steampowered.com/client/steamcmd_linux.tar.gz
tar -xvzf steamcmd_linux.tar.gz
./steamcmd.sh

Then

./steam.sh
| improve this answer | |
  • 2
    There is no need to use find and grep. find alone is sufficient. – edwinksl Sep 20 '16 at 6:52
1

As of time of this post, using Ubuntu 20.04 LTS, I first tried installing using steam_latest.deb from their website, but got the OP error.

To resolve I ran this in terminal:

sudo apt-get install steam

And it would work after.

| improve this answer | |
  • Not working on my Ubuntu 18. – Sklavit Jun 14 at 16:09
  • @Sklavit Does apt-get find the package at all on Ubuntu 18? In my case Steam was able to function but finally the game I was trying to play only worked on Steam for PC T_T. Can you try sudo apt-get install steamcmd as well? (untested, but I saw it on someone else's response) – Wadih M. Jun 14 at 18:07
  • Linux Mint 19.3 here. This actually worked. Thanks! Apparently, dpkg did not attempt to install the dependencies. Running sudo apt-get install steam right after fixed the issue for me. – JulioHM Jun 20 at 0:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.