0

I'm providing some of the terminal tests I done for a Dell latitude D520 with Ubuntu 12.04. Please any help will be appreciated.

PCI:

lspci

02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02) 
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

Network Devices:

ifconfig -a 
eth1      Link encap:Ethernet  HWaddr 00:19:b9:71:8b:fb  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1 
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0 
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B) 
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0 
          inet6 addr: ::1/128 Scope:Host 
          UP LOOPBACK RUNNING  MTU:16436  Metric:1 
          RX packets:1165 errors:0 dropped:0 overruns:0 frame:0 
          TX packets:1165 errors:0 dropped:0 overruns:0 carrier:0 
          collisions:0 txqueuelen:0 
          RX bytes:120890 (120.8 KB)  TX bytes:120890 (120.8 KB) 

wlan0     Link encap:Ethernet  HWaddr 00:1b:fc:53:d9:c6  
          inet addr:192.168.1.105  Bcast:192.168.1.255  Mask:255.255.255.0 
          inet6 addr: fe80::21b:fcff:fe53:d9c6/64 Scope:Link 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1 
          RX packets:23937 errors:0 dropped:0 overruns:0 frame:0 
          TX packets:20346 errors:0 dropped:0 overruns:0 carrier:0 
          collisions:0 txqueuelen:1000 
          RX bytes:20576514 (20.5 MB)  TX bytes:2424136 (2.4 MB) 

Local Networks:

nm-tool 

NetworkManager Tool 

State: connected (global) 

- Device: eth1 ----------------------------------------------------------------- 
  Type:              Wired 
  Driver:            b44 
  State:             unavailable 
  Default:           no 
  HW Address:        00:19:B9:71:8B:FB 

  Capabilities: 
    Carrier Detect:  yes 

  Wired Properties 
    Carrier:         off 


- Device: wlan0  [kouts103] ---------------------------------------------------- 
  Type:              802.11 WiFi 
  Driver:            b43 
  State:             connected 
  Default:           yes 
  HW Address:        00:1B:FC:53:D9:C6 

  Capabilities: 
    Speed:           54 Mb/s 

  Wireless Properties 
    WEP Encryption:  yes 
    WPA Encryption:  yes 
    WPA2 Encryption: yes 
8
  • 1
    I know it sounds silly but what happens when you plug the ethernet cable in and then click on auto eth0 from the dropdown network menu?
    – mchid
    Mar 29, 2015 at 3:05
  • Hi mchid, nothing happens. with my limited knowledge I think the problem is in the driver b44 is unavailable or Kernel can't see the driver.
    – GEORGE
    Mar 30, 2015 at 4:14
  • Hey, can you please post the output of lspci -knn | grep -A 3 Ethernet to show that the device is using the driver; it will show "driver in use:" and other usefull info that can help. Although it looks like the driver is enabled, you can run sudo modprobe b44 to enable the kernel module and lsmod | grep b44 to verify that it is indeed loaded by the kernel.
    – mchid
    Mar 30, 2015 at 5:43
  • see if this helps askubuntu.com/questions/71159/…
    – mchid
    Apr 21, 2015 at 18:13
  • 1
    Possible duplicate of Ethernet Network card BCM4401-B0 no longer recognised?
    – Pilot6
    Feb 2, 2016 at 19:31

2 Answers 2

1

Edit:

Okay, from what you have listed, the problem appears to be your file /etc/NetworkManager/NetworkManager.conf. Open a terminal and execute the following commands:

sudo nano /etc/NetworkManager/NetworkManager.conf

Make sure the file says the following, nothing more and nothing less:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

Then, press CTRL + o to save the file and press CTRL + x to exit the file.

Also, edit /etc/network/interfaces:

sudo nano /etc/network/interfaces

and make sure that file has only these contents:

auto lo
iface lo inet loopback

Again, press CTRL + o to save the file and press CTRL + x to exit the file.

Finally, execute the following commands and then connect the ethernet cable and it should automatically detect and switch to the wired connection:

sudo service network-manager restart

To explain: You do not want the network as "managed" because you want to use "auto" instead. Also, you had the default device set to wireless for some reason. Both of those together along with the "no-auto-..." flag basically disabled your auto ethernet.

Normally, however, when the system has a wired and a wireless connection, the wired connection will always be favored and used even when they are both connected because eth0 should be the default device by default.



First:

Unplug in your ethernet cable and run the following commands from an open terminal:

sudo mkdir /etc/NetworkManager/connections-backup
sudo mv /etc/NetworkManager/system-connections/* /etc/NetworkManager/connections-backup

sudo service network-manager restart

Plug the ethernet cable in. Click on the network-manager icon on your desktop panel to open the dropdown menu. Then, click on "Auto eth0"

enter image description here

If you see some message similar to "device is not managed" or "device is managed" please let me know and I'll post instructions on how to get around that.

If the network doesn't come up like it's supposed to after plugging in the ethernet cable, run the following command to refresh network-manager:

sudo service network-manager restart

Or, run these commands to unload and reload the driver:

sudo modprobe -r b44
sudo modprobe b44

If it says that b44 is in use, run

lsmod | grep b44

and it should show what module is using b44. Use

sudo modprobe -r 

followed by the module name you wish to disable before pressing enter.

Then, use

sudo modprobe b44 

to load the driver again.

Make sure your firewall is not blocking ports 67, 68, or 53 (dhcp, dhcp, and dns respectively). If you have not done anything to explicitly block these ports they are most likely not blocked as you would've had to have set a rule yourself to block them.

6
  • Hi mchid, sorry for the delay. I have tried what you suggested: sudo mkdir /etc/NetworkManager/connections-backup sudo mv /etc/NetworkManager/system-connections/* /etc/NetworkManager/connections-backup command not found sudo service network-manager restart network-manager stop/waiting network-manager start/running, process 2424 and I connected the ethernet cable and voilà!! worked like a charm!! thank you very much mchid!!!
    – GEORGE
    Apr 1, 2015 at 13:33
  • Hi mchid, when i shutdown the laptop and restarted, the ethernet was lost.when I run the command: lsmod | grep b44 b44 31364 0 ssb 50691 2 b44,b43 b44 showns in red color. please help
    – GEORGE
    Apr 1, 2015 at 20:03
  • @GEORGE those are in red because you used grep to search for them so the results show in red. Try restarting network-manager again and see if it worked like last time. If a network exists for eth0 you may need to erase it so the network can set it self up again.
    – mchid
    Apr 4, 2015 at 17:11
  • @GEORGE oh yeah, that also means those drivers are currently loaded and in use
    – mchid
    Apr 4, 2015 at 20:44
  • Hi mchid, I tried network-manager, no luck. I have followed your suggestion: sudo modprome -r b44 to reveme b44 from: ssb module ssb 50691 2 b43 and removeded. Then, use sudo modprobe b44 to load the driver again. put it pouts it back with b33 at module ssb. Sorry for the delay, this week we having the grand kinds. an help will be appreciated.
    – GEORGE
    Apr 8, 2015 at 1:47
0

Finally suspected the Ethernet port not working,and at, system setting / network showed wired unplugged. I ordered from ebay "USB to Ethernet connector" and soonest i connected, Ethernet became live.

1
  • That could be very easily fixed. See the duplicate link.
    – Pilot6
    Feb 2, 2016 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.