0

Sometimes windows, dialogs (gnome, KDE) go black and only the decoration as the titlebar remains and its buttons work as well. It happens a few times a within 10 hours continuously working. More or less twice a hour.

here the setup:

  • tripple monitor, NVIDIA default driver
  • Ubuntu latest LTS (14.010), x64 with no tweaks or mods/other window-manager installed. All on default, just Oracle-Java instead of OpenJDK.
  • lshw -C display: PCI (sysfs)

    *-display
    description: VGA compatible controller product: GK107 [GeForce GT 640] vendor: NVIDIA Corporation physical id: 0 bus info: pci@0000:03:00.0 version: a1 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress vga_controller bus_master cap_list rom configuration: driver=nvidia latency=0 resources: irq:64 memory:fa000000-faffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:fb000000-fb07ffff

other notices:

  • It comes with multiple Java-Applications (PHP/Webstorm, Eclipse) and seems to affect other applications as well: Chrome, Krusader and also gnome dialogs or any other gnonme based applications.

  • Keyboard goes off in Java applications, no idea this is related but it happens the same rate as the window problem.

    • it came with the 14.4 update

current solution:

  • press escape to close dialog or application (crucial sometimes) and redo the step.

As I don't have anything special installed I'd love to know what to do about, its sometimes more frequent and really annoying.

ps: there is a duplicate about but not well described or supported: https://askubuntu.com/questions/553293/windows-sometimes-go-black

1
  • What graphics and drivers do you have? (you can use lshw -C display and edit it into your question)
    – Wilf
    Mar 29, 2015 at 5:57

1 Answer 1

0

It might be this bug in compiz. As far as I am aware of the current daily image of 15.04 should have this fixed. You could try that and see whether that helps.

4
  • Unity uses compiz, but Gnome and KDE use other window managers...
    – Wilf
    Mar 29, 2015 at 5:56
  • Oh yeah that's true. My bad.
    – cstich
    Mar 29, 2015 at 11:05
  • Hi, turning off animations via Compiz-Settings solved it :-) Mar 29, 2015 at 18:50
  • Glad you found a solution :)
    – cstich
    Mar 30, 2015 at 13:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .