6

On Xubuntu 14.04 I have installed the package transmission-daemon. It appears to start automatically when I start the computer. Is it possible to prevent this from happening and instead I would like to start it manually.

additionally if I would like to restore it to autostart sometime in future, please advise how to do that as well..

Thanks,

Edit : Useful link to restore it again Here

5

Check /etc/default/transmission-daemon config file.

In it, set ENABLE_DAEMON=0, and it won't autostart.

2
  • Thanks, additionally can you tell me what relation does it have with file here /etc/init.d/transmission-daemon ?? – Ahmed Mar 28 '15 at 23:08
  • Just another config file. – mikewhatever Mar 28 '15 at 23:17
7

On newer versions using systemd it is a bit different.
Check if it is enabled with:
systemctl status transmission-daemon.service
Which will return something like: transmission-daemon.service - Transmission BitTorrent Daemon Loaded: loaded (/lib/systemd/system/transmission-daemon.service; enabled;

The enabled; means it will start on boot. To stop from starting on boot run:
sudo systemctl disable transmission-daemon.service

Now check the status again: transmission-daemon.service - Transmission BitTorrent Daemon Loaded: loaded (/lib/systemd/system/transmission-daemon.service; disabled;

It should now be disabled;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.