0

I posted a while ago with this problem: https://askubuntu.com/questions/597113/14-10-upgrade-no-access-to-menus-or-sidebar, which I cannot find a workaround, especially as I can't access the Terminal via Ctrl+Alt+ T, and none of the login/passwords that I can think of will get me into the tty terminals. I can't boot into safe mode either.

Does anyone know another way to open a terminal? Is there a file on the computer I can access directly?

  • Possible duplicate of Unity doesn't load, no Launcher, no Dash appears – Sergiy Kolodyazhnyy Mar 29 '15 at 1:44
  • Also, this might be simplest solution – Sergiy Kolodyazhnyy Mar 29 '15 at 1:46
  • Would that matter if I don't have nvidia anything in my machine? – rougon Mar 29 '15 at 1:48
  • Shouldn't. It happens regardless of the graphics card. I have amd and it happened to me before. Solved by installing gdm greeter then reinstalling lightdm – Sergiy Kolodyazhnyy Mar 29 '15 at 1:50
  • I tried all of those solutions, but none of them changed anything. Some, I think, were outdated. I also got an error message whenever I tried to use a line that included "-f". Any further thoughts? – rougon Mar 29 '15 at 22:46
1

Try pressing Ctrl+Alt+F1. That should allow you to enter tty1. If that doesn't work, try Ctrl+Alt+F2, Ctrl+Alt+F3, etc. etc.

It will say something like:

Ubuntu 14.10 ComputerName tty1

ComputerName Login:

Type your username here and hit enter, and then your password.

You should be able to access tty and go from there.

  • Thanks! I got there and I hate to admit that I just used the wrong username for the past week. – rougon Mar 28 '15 at 21:55
  • Any idea how to get the menus and launcher back from there? – rougon Mar 28 '15 at 21:55
0

It might be an error in lightdm. Try installing gdm and uninstall lightdm and reboot and see if that works

If that doesnt work uninstall gdm and reinstall lightdm. Reboot. Then enter unity-tweak-tool --reset into tty. Reboot. See if that works

  • Thanks for the suggestions. Unfortunately there is no change. I installed gdm, as we'll as installed the tweak tool and reset it, but nothing happened. Would it work to downgrade back to an earlier os that worked? – rougon Mar 28 '15 at 23:10
  • Are you using a nVidia graphics card? – The5heepDev Mar 28 '15 at 23:17
  • I actually don't remember. It's been a couple of years. How would that affect it? – rougon Mar 28 '15 at 23:21
  • There are some bugs with the nVidia drivers that will do that – The5heepDev Mar 28 '15 at 23:23
  • Will I see that if I take the cover off? – rougon Mar 28 '15 at 23:26
0

Try this fix:

From a terminal:

sudo apt-get update
sudo apt-get install unity
dconf reset -f /org/compiz/

This will reinstall unity and reset the config.

If that doesn't work then:

sudo apt-get update
sudo apt-get install ubuntu-desktop
rm --recursive /home/user/.config/dconf/user

but be aware that this solution will install all of the packages from ubuntu-desktop (including things like gedit, sound utility, archive managers etc.)

  • That's fine as long as it doesn't wipe files! – rougon Mar 29 '15 at 0:36
  • I doesnt. It only removes some config files – The5heepDev Mar 29 '15 at 0:42
  • I'm getting "command line option 'f' [from -f] is not known" on both of those. – rougon Mar 29 '15 at 1:16
  • oops fixed the commands – The5heepDev Mar 29 '15 at 1:27
  • I got the same message with -rf, ie not recognizing r from -rf ? – rougon Mar 29 '15 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.