Tried to install 10.10 yesterday and eventually got an error that Grub had failed to install. Asked me to select another partition, cancel install or continue without a bootloader.

Everytime I selected another partition the error would just pop back up immediately (not convinced it even tried writing anything to disk).

I did do some partitioning when I was in the installer - shrunk an ntfs partition and grew the Linux one to make up for it - the defaults were set to place at beginning of drive and logical (as opposed to primary), so I left it with that.

The first time grub just went to the recovery prompt - but most of the commands that were 'supposed' to work, didn't (been reading articles and how-tos). After another reinstall and an attempt to install manually I got through to the grub> prompt, but have failed to get much further.

I've checked the grub directory and there's no grub.cfg anywhere, but it's definitely 1.9x that's installed. There should be no Legacy Grub installations anymore, that I'm aware of.

Have gone through various methods to try and load a kernel or configure grub but they've all been unsuccessful. For example: http://ubuntuforums.org/showthread.php?t=1195275


Sorry, you're right, I should have been clearer, left a lot of space for assumptions there. Was writing it while researching/rebooting.

I have actually managed to work around it, but I will get back with that partition table 'cause I'm pretty sure something is wrong somewhere - still unable to get the distro installer to install grub, as it should.

Using Ubuntu Linux. Was failing to get past the grub> prompt because I wasn't loading the initrd image. Did that and I was flying. Just ran update-grub once I got into Ubuntu proper.

  • suggest trying an alternate distro? run a quick install of puppy linux / damn small linux and see if you get this working. At this point you'll have a working grub2 install, it seems to reason to me. – emf Oct 13 '10 at 6:07
  • If you got your problem fixed, you should mark this thread as Solved – emf Oct 13 '10 at 19:12

In my opinion, you try to install by selecting 'continue without a bootloader', when you finish, reboot your computer with a liveCD or LiveUSB again. after being on the desktop, try to reinstall grub with the steps:

mount ubuntu partition that you installed earlier. you can click on places > your-ubuntu-partition

open terminal, run:

sudo chroot /media/your-ubuntu-partition

sudo grub-install /dev/sda

sudo update-grub

close the terminal, and try to reboot it.

| improve this answer | |
  • Cheers, that's basically what I did. (almost) Grub wouldn't update/config in the LiveCD session, had to get into a real one first. If anyone else reads this, remember to load both the linux kernel AND the intrd.img (command works the same way). – Kubular Oct 16 '10 at 0:18

Your post has been viewed 12 times now with no replies. That may be because you have provided little information for anyone to understand your situation. Specifically:

  • you have not listed your partition table and said what each partition is
  • you said you were installing 10.10 but said you resized a linux partition (of what Linux?)
  • you said you checked the "grub directory", but which one? /boot/grub/ is where it should be for grub2 which is default for a clean install.

There definitely CAN be legacy grubs around if you have been doing upgrades rather than new installs.

Have you tried installing GRUB2 from a live CD following the instructions on the page you referenced or on https://help.ubuntu.com/community/Grub2 which I believe is more recent than your reference (though it may have been created based on the reference you gave)?

| improve this answer | |
  • Sorry, you're right, I should have been clearer, left a lot of space for assumptions there. Was writing it while researching/rebooting. – Kubular Oct 13 '10 at 18:00
  • how can I get a partition table out of the terminal? – Kubular Oct 13 '10 at 18:10
  • @Kabular to dump the partition table, try fdisk -l or sfdisk -l -- or just ask a new question on this site :-) – Riccardo Murri Oct 13 '10 at 18:14
  • Disk /dev/sda: 320.1 GB, 320072933376 bytes 255 heads, 63 sectors/track, 38913 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0xdeb64491 Device Boot Start End Blocks Id System /dev/sda1 1 24352 195599609+ 7 HPFS/NTFS /dev/sda2 24352 38560 114130859+ 83 Linux /dev/sda3 38560 38914 2839553 5 Extended /dev/sda5 38560 38914 2839552 82 Linux swap – Kubular Oct 16 '10 at 0:15

Well sounds to me he wants to dual boot. I had the same problem because Ubuntu wouldn't mount the partition i had and it was not "bootable". Use the CD to use Disk utility and make the partiton bootable and mount it.

| improve this answer | |

Had the same problem while tryin to ugrade from 9 to 10.10(ubuntu),so a quick and dirty fix i reinstalled 9 then popped in 10.10,i didnt format drives,didnt give me the "cant install bootloader"(on any partition/drive) hope this helps :)

| improve this answer | |

Here's the piece I was missing. You have to make sure your /boot/grub/device.map is correct before you do: grub-install:

what:/boot/grub# cat device.map

(hd0) /dev/cciss/c0d0

i had to correct to:

(hd0) /dev/sda

before I could run:

/sbin/grub-install /dev/sda

for grub version .97 (1)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.