6

Had some problems with my laptop a few days ago and I had to reinstall the system. I used the same password for the same user when I installed it and, after the installation finished, when I got to the login screen and entered my password, I got bounced back. I switched to tty1 and after logging in I got this:

Signature not found in user keyring
Perhaps try the interactive 'ecryptfs-mount-private'

I ran the command and entered my passphrase, but it didn't work. I did know my passphrase. I thought that the encryption files got corrupted somehow. I don't know how, but after lots of tries, system reinstallations and restarts (over a few hours), it worked eventyally (the same passphrase that initially didn't). I then rewrapped a new passphrase.

The problem I am encountering now is that every time I restart my computer the partition doesn't decrypt automatically when I enter my password on login. I always have to switch to tty1 and run ecryptfs-mount-private from there.

I tried many ecryptfs commands (unwraping and rewraping the passphrase), but nothing seems to work: ecryptfs-unwrap-passphrase, ecryptfs-rewrap-passphrase, ecryptfs-insert-wrapped-passphrase-into-keyring. The passphrase seems to be inserted in the keyring only for the session.

Is there any way I can make this permanent?

7

Solved it with

ecryptfs-rewrap-passphrase /home/my_user/.ecryptfs/wrapped-passphrase

The problem was that when I tried rewrapping the passphrase I was trying to set a passphrase different than my account password. It worked when I set it the same as my account password.

  • If one runs ecryptfs-rewrap-passphrase and gets the error message "Passphrase is too long. Use at most 64 characters long passphrase.", this solution won't work and means that the problem is that the new password is too long and the encrypted directory is still encrypted with the old password (which should be less than 64 characters). Simply using passwd to change the password back to the previous password should make it possible to log in via the GUI. – Patrick Dark May 1 '18 at 21:21
0

I had the very same problem when updating my laptop from 12.04.5 to 14.04.2.

After fiddling around and (more or less willingly) deleting my "wrapped-passphrase" I used "ecryptfs-wrap-passphrase /home/my_user/.ecryptfs/wrapped-passphrase" with the mount-passphrase as "Passphrase to wrap:" and my login password as "Wrapping passphrase".

After that login is working again.

  • No work for me, I lost passphare – ghanbari May 7 '17 at 15:22
0

I had a "$" sign in my password, had to escape it with a "\$".

e.g.

printf "%s\n%s" "4543245543gdsgfgssg23445" "loginpa\$s" | ecryptfs-wrap-passphrase /home/$user/.ecryptfs/wrapped-passphrase -

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.