2

I recently installed Ubuntu 14.04 on my Samsung Ativ Book 6 (NP680Z5E-X01US).

Since then I am completely unable to modify my brightness settings. The Fn buttons work fine, if I press Fn+F2/F3 I can see the brightness slider, but no change happens until I push it down to where it deactivates the screen. Also, there is no response from the keyboard backlight. Other work fine (audio, wifi, mousepad-lock)

I have tried several options and I am essentialy in the same spot of the user here:

Can't adjust brightness on my MSI VR420 laptop

What I tried:

  • Edit /etc/default/grub ↦ GRUB_CMDLINE_LINUX_DEFAULT: acpi_osi=Linux, acpi_backlight=vendor (as well as several different combinations of these settings being on or off)

  • Edit /etc/X11/xorg.conf (file doesn't exist on my system)

  • sudo setpci -s 00:02.0 F4.B=XX (does nothing)

  • xbacklight -set XX (does nothing)

  • install indicator-brightness (changing its value does nothing)

Checking the folder

ls /sys/class/backlight/intel_backlight/

shows that

max_brightness = 4882

while

actual_brightness
brightness

change as I move the slider in step of 244, but no corresponding change in brightness happens.

My graphic card is

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)       

I also have a Radeon

01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8670A/8670M/8750M] (rev ff)
4
  • Did you run sudo update-grub after editing /etc/default/grub? Otherwise the changes would have no effect...
    – Byte Commander
    Mar 28, 2015 at 12:48
  • Yep, I did to no avail
    – Three Diag
    Mar 28, 2015 at 13:09
  • Then I have no idea what to do next. But we have an incredible number of questions about brightness control here on AU. Did you already use the search and try some suggestions? If yes, add what you did and how Ubuntu reacted - if not, do so!
    – Byte Commander
    Mar 28, 2015 at 13:12
  • I have tried all that I could find on the forum, updated drivers, installed xbacklight, edited/created config files and there is no response whatsoever
    – Three Diag
    Mar 28, 2015 at 14:10

2 Answers 2

0

I managed to solve this by doing a fresh 14.04 install, the screen brightness commands now works right after the install without any trick needed. I reinstalled after upgrading to 14.10 bricked my graphic interface.

0

I've found a solution for my case after a few days of despair.

It consists in using these options in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=video"

I have a Samsung laptop model NP470R4E running Ubuntu 16.10.

Here is the source of this miracle: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1485246/comments/14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.