1

I installed web version of transmission on my Ubuntu Server 14.10

To make it work with my home folder I did this:

cd /home/nat/Downloads

mkdir transmission

sudo usermod -a -G debian-transmission nat

sudo chgrp -R debian-transmission /home/nat/Downloads/transmission

sudo chmod -R 775 /home/nat/Downloads/transmission

Then I changed unmask to "2" in /etc/transmission-daemon/settings.json

Everything worked well but I decided to do all this steps with my HDD (it is Ext4) that mounted at /media/nat/1

cd /media/nat/1

mkdir transmission

sudo chgrp -R debian-transmission /media/nat/1/transmission

sudo chmod -R 775 /media/nat/1/transmission

But it doesn't work.

When I try to load a torrent it says:

Error: Permission denied (/media/nat/1/transmission/)

What am I doing wrong?

P.S.

nat@nat:/media/nat/1/transmission$ ls -l

total 12 drwxrwxr-x 2 nat

debian-transmission 4096 марта 28 06:06 completed drwxrwxr-x 2 nat

debian-transmission 4096 марта 28 06:06 incomplete drwxrwxr-x 2 nat

debian-transmission 4096 марта 28 06:06 torrents

And I tried changing USER in sudo nano /etc/init.d/transmission-daemon It doesn't help.

1

OK, Problem is solved.

It was in mounting of my HDD. Automatically system gived me minimal rights. So I formatted my HDD to NTFS and added it to /etc/fstab

First find UUID of your diks

ls -l /dev/disk/by-uuid

then edit fstab

sudo nano /etc/fstab

add new line

UUID={your uuid} /mnt/nat ntfs-3g 0 0

reboot system and add new download rout to /etc/transmission-daemon/settings.json That's all, No need in steps from previous post.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.