1

Got camera-app, revno: 542. Host - 14.04, Ubuntu SDK.

Target Desktop

getting runtime qml error when trying to run the 'camera' run configuration:

file:///home/user/camera-app/camera-app.dev/camera-app.qml:24:1: module "CameraApp" is not installed 
     import CameraApp 0.1 
     ^ 

Target ubuntu-sdk-14.04-i386

getting packager error when trying to run the 'camera' run configuration:

Could not find the manifest.json file in /home/user/camera-app/build-camera-app.dev-UbuntuSDK_for_i386_GCC_ubuntu_sdk_14_04_trusty-Default/.ubuntu-sdk-deploy.

Target ubuntu-sdk-14.04-i386 -DCLICK_MODE=on

(with cmake options '-DINSTALL_TESTS=off -DCLICK_MODE=on')

getting wrong architecture in package configs when trying to run 'camera' run configuration:

Warning: Permanently added '[127.0.0.1]:10000' (RSA) to the list of known hosts.
Sdk-Launcher> Executing:     /tmp/com.ubuntu.camera_3.0.0.latest_armhf.click
Sdk-Launcher> Force Install: False
Sdk-Launcher> Skip Uninstall:False
Sdk-Launcher> Launcher PID: 32296
Sdk-Launcher> Installing application .....
Transaction:    Installing files
Status:     Waiting in queue
Status:     Starting
Status:     Finished
Transaction:    Installing files
Status:     Waiting in queue
Status:     Waiting for authentication
Status:     Waiting in queue
Status:     Starting
Status:     Finished
Results:
Fatal error: /tmp/com.ubuntu.camera_3.0.0.latest_armhf.click failed to install.
WARNING:root:Signature check failed, but installing anyway as requested
Cannot install /tmp/com.ubuntu.camera_3.0.0.latest_armhf.click: Package architecture "armhf" not compatible with system architecture "i386"

Sdk-Launcher> Installing the application failed

After editing the initial manifest.json to have i386 architecture, the package can be installed. But there is a runtime error:

Debug-helper> Setting up environment
Debug-helper> TmpDir:      /home/phablet/.local/share/com.ubuntu.camera/
Debug-helper> AppId:       com.ubuntu.camera_camera_3.0.0.latest
Debug-helper> Environment: confined
Debug-helper> Environment initialized, starting the application
Debug-helper> Executing ./camera-app['./camera-app']
./camera-app: symbol lookup error: ./camera-app: undefined symbol: _ZN6QDebugD1Ev

Target ubuntu-sdk-14.10-armhf -DCLICK_MODE=on

(with cmake options '-DINSTALL_TESTS=off -DCLICK_MODE=on')

Runs the app, but slowly.

What can I do to get something running on Desktop or on the sdk-14.04-i386?

ubuntu-terminal-app works for me on ubuntu-sdk-14.04-i386 out of box.

0

This message:

./camera-app: symbol lookup error: ./camera-app: undefined symbol: _ZN6QDebugD1Ev

makes me believe you compiled it with a 15.04 Kit and are trying to run on a 14.10/RTM device/emulator.

Try again with either both on 15.05 or both on 14.10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.