I am using Ubuntu 14.04LTS. Recently, I needed to use remote control of my computer in my office. So I set up desktop sharing. I can use my own laptop to control my desktop when I am in the office, however, when I go back home, it doesn't work. I tried to turn off firewall, but it didn't work either.

Does anyone have any idea what's going on here?

  • Please edit your question and explain how you set up desktop sharing. Are you using an IP or a server name? Are your laptop and desktop connected to the same network?
    – terdon
    Mar 27, 2015 at 13:02

1 Answer 1


I will be answering your question as I understand it (not that well):

  • you have a PC (PC-1) at work that you enabled desktop sharing
  • you used another PC (PC-2) at work (on the same network) to successfully remote into PC-1
  • you went went on a home PC (PC-3; different network) & couldn't successfully connect to PC-1 in office

Its because of your router/firewall configuration on your work network-ie SECURITY. Someone will need to port-forward/allow port 5900 (assuming its VNC) on that work router/firewall

  • Hey, thanks for your help! I'v talked to my network security and they help me solve the problem. It's because port 5900 has already been used. But I can use realVNC to connect with my PC in office. Apr 5, 2015 at 19:46
  • No problem. Would you mind marking it as the answer?
    – gregg
    Apr 6, 2015 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.