0

I am trying to set up a static IP address using the nm-connection-editor tool. I select the currently-used wireless network, click edit, go to "IPV4 Settings", click add, enter a valid IP address, Netmask, Gateway, and DNS Server address. I click save.

I use nm-tool to check if the settings have been updated. They haven't. I re-connect to the network in question. Upon clicking "edit connections", I see that a new "connection" has been generated, named [name of old connection] 2 and the old one has been renamed to [oldname] 1. Restarting does not change this. I read that in order to let the GUI-based tool handle the network, I had to comment out all lines without "lo" in them in /etc/network/interfaces, so I tried that, but it did not change anything.

I have attempted to set up a static internal IP address by modifying /etc/network/interfaces, by adding this (same settings were used in nm-connection-editor):

 auto wlan0
 iface wlan0 inet static
 address 192.168.2.45
 netmask 255.255.255.0
 gateway 192.168.2.1

I have checked that it is the correct gateway and other settings multiple times. Adding those lines, however, only made nm-tool report that neither wlan0 nor eth0 are managed.

My questions:

  • How am I supposed to use /etc/network/interfaces to setup a static IP address; specifically, how does that differ from what I am doing here? Obviously something is wrong.

  • How am I supposed to use nm-connection-editor to setup a static IP address; specifically, what have I done wrong?

  • If I haven't done anything wrong, is this a bug?

  • What other information can I provide to help identify the problem?

I am running 32-bit Lubuntu 14.10 on a Dell Latitude D630 (Core 2 Duo processor, 2GB DDR2 RAM, Broadcom BCM4311 R01 wireless adapter).


UPDATE: Some bizarre stuff has been happening - each new "connection" (of the aforementioned form "[oldconnectionname] 1, 2, 3....") asks for the WPA password for the network each time it is created, but does not store it (in Wi-Fi Security). Despite this, every time I try reconnecting after the new "connection" is created, it does not re-ask for the password.

I have confirmed that setting a static IP address works doing the exact same thing (with different numbers, but also taken from the same output of nm-tool) with a different internet connection works - I successfully modified the connection properties to a different home wireless router connected to the same network. Which is strange, because previously changing the same settings on a windows machine connected to the same router experiencing troubles now had no difficulty.

1

I am newer to linux but to manually configure your static ip should be as follows


sudo vim /etc/network/interfaces or whatever editor you prefer

 auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
address 192.168.10.2
netmask 255.255.255.0
gateway 192.168.10.1
network 192.168.10.0
broadcast 192.168.10.255

follow changes with

sudo ifdown wlan0 then 
sudo ifup wlan0 
sudo dhclient

this is my scheme change addresses to match yours e.g. broadcast is .255 at then end network would be .0 Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.