I've got a laptop with Sandy Bridge + Hybrid Graphics and I want to use linux in it. I've tried fedora 15 with no luck (the Radeon not detected but always on and runs with max performance, introducing heat problems).

I've tried the open source radeon driver, the proprietary driver, and in fedora, it just didn't work. Everytime I installed a radeon driver, I can't boot anymore (and have to uninstall it from terminal). The Intel video only works with VESA mode, and I can't get a decent performance with it. Even then, there's still the heat problem that basically make the laptop unusable for more than 15 minutes.

So now I'm looking for another distro. Does ubuntu support this configuration yet? (I don't want to download another distro and find that it doesn't works with my configuration.

I'm aware of this question, but it's been three months. Are there any improvement since? I've also search a solution a lot, but currently can't find anything.

Here's the full specification of the laptop (HP Pavillion g4-1004tx):

  • 2.3 GHz Intel Core i5-2410M
  • 4 GB 1333 MHz DDR3
  • AMD Radeon HD 6470M (1 GB DDR3) / Intel HD Graphics 3000 (Shared Memory)
  • 500 GB SATA (5400 rpm)
  • LightScribe SuperMulti DVD±R/RW with Double Layer Support
  • Altec Lansing speakers - SRS Premium Sound
  • Broadcom 4313 802.11b/g/n Bluetooth WiFi (HW ID: PCI\VEN_14E4&DEV_4727&SUBSYS_1483103C&REV_01)
  • Integrated 10/100 BASE-T Ethernet LAN


I've confirmed that it didn't work. It didn't even show the splash screen (the Ubuntu loading screen) after boot.

Setting nomodeset and acpi=off while booting shows the splash screen, which eventually gives error message basically like this:

Bad LUN...
Bad Target...

And finally, I confirmed it didn't work and find the same problem here. Maybe the next release will fix this.

  • 1
    i5 2410M with AMD HD6650M here and not a single issue with it so an older graph card should work just as well :)
    – Rinzwind
    Sep 5, 2011 at 18:11
  • Didn't work for me - didn't even boot. :(
    – bertzzie
    Sep 6, 2011 at 16:36

2 Answers 2


Intel-AMD switchable graphics is a no go (for now), Nvidia's Optimus works (kinda...) but support is still flaky.


I have video card AMD Radeon HD6470M and it works fine under Ubuntu 11.04.

You need to install proprietary driver Catalyst/fglrx.

I hope These instructions will help to solve your problems with video card.

It's an important for the first to remove previously installed driver before you install Catalyst, don't forget it and follow mentioned instructions attentively

EDIT: Actually it works also on Ubuntu 10.10.

EDIT 2: You could try XSpiritusX Solution to the switchable-graphics problem

  • Well, like I said in the question, I can't even get into the installation screen. I've follow trough your link and it assumed that the system is already installed. Is there a way to load the driver before installing the OS? Also, is your laptop also use switchable graphics?
    – bertzzie
    Sep 7, 2011 at 15:43
  • Actually not, my video card don't run switchable graphics. Sorry, my bad. Surely switchable graphics it's another story. I've just edited my answer. Hopefully, it could be helpful in your case.
    – Justas
    Sep 7, 2011 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.