7

My processor is Intel core i3 inside x64 bit and RAM is 4 gb. When I used Windows 7 Intel was successfully installing, but now I am using Ubuntu 14.04 and Intel Installer makes me crazy!!! I've tried to change lsb-release, but is doesn't help me. I tried to reinstall signature and Intel Installer, but everything is the same!

I heard this problem was on Ubuntu 14.10, but not on Ubuntu 14.04.1 LTS. If someone knows why I have this error please help me...

enter image description here

5

Most versions of the Linux operating system include Intel graphics drivers. Intel recommends checking with your Linux distribution vendor or computer manufacturer for precompiled driver packages.Intel

The Intel Graphics Installer for Linux allows you to easily install the latest graphics and video drivers for your Intel graphics hardware. This allows you to stay current with the latest enhancements, optimizations, and fixes to the Intel® Graphics Stack to ensure the best user experience with your Intel graphics hardware. The Intel Graphics Installer for Linux is available for the latest versions of Ubuntu.

NOTE (updated 18 March 2015 09:15 UTC-7): This release of the Graphics Installer requires Ubuntu 14.10 "utopic". The Graphics Installer will not function on Ubuntu 14.04 "trusty" and support is deprecated (see this forum announcement and this explanation).The Intel Graphics Installer for Linux

You can try using the older driver, but I have no way of verifying that it will work. Depending on your needs, download the 32bit or 64bit or you can download the file from source: for 32bit or 64bit and then follow the commands below:

wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | sudo apt-key add -
sudo apt-get update
For 32 bit:
sudo dpkg -i intel-linux-graphics-installer_1.0.7-0intel1_i386.deb
OR for 64 bit:
sudo dpkg -i intel-linux-graphics-installer_1.0.7-0intel1_amd64.deb

And then just start the installer

sudo intel-linux-graphics-installer

I would recommend you install the file(s) using Gdebi. To install:

sudo apt-get install gdebi
  • can i change my lsb-release and instead of 14.04 write 14.10, instead of trusty write utopic? – Tony Stark Mar 27 '15 at 4:45
  • You really don't have to install anything. just do lshw -c video to see driver loaded. also take a look at this. – Mitch Mar 27 '15 at 6:16
  • If the answer was helpful to you, then please consider marking it as the accepted answer so others may more easily find it in the future. This is also a polite way to thank the person answering your question for helping you out. – Mitch Mar 28 '15 at 9:40
  • Without installing anything, I have the missing letters problem, like many others. – Dan Dascalescu Mar 30 '15 at 11:37
  • 1
    The answer worked for the OP, so I guess I don't understand why it doesn't work for others, and the downvotes :) – Mitch Apr 4 '15 at 18:05
3

Because the installer could not work with 14.04.2 (HWE) or if a 14.04.1 user of the installer tried to install the lts-utopic mesa stack they've dropped any further support for 14.04.x

Read here for announcement - https://01.org/linuxgraphics/node/471

Personally don't think the Intel installer provided anything of real value, at least here with Haswell (mobile)

Updates for libva & vaapi are available from several ppa's, search if interested there.

  • is there other methods to install intel graphicks or i must to upgrade to 14.10? – Tony Stark Mar 27 '15 at 4:47
  • @tony just download the older version for 14.04 directly from the repository download.01.org/gfx/ubuntu/14.04/main/pool/main/i/… – mchid Mar 31 '15 at 9:10
  • I install 1.07 version but still got same error, any idea? – Daniyal Apr 30 '15 at 16:06
  • " install 1.07 version but still got same error, any idea? – Daniyal" The installer is, as mentioned, worthless in 14.04. So best 'idea' is - accept that FACT. – doug May 1 '15 at 10:05
1

How did i install intel linux graphics driver and it works for me:

For Ubuntu 14.04 with kernel linux-image-3.16.0-30:

1. Install kernel If not yet installed:

$ sudo apt-get linux-image-3.16.0-30-generic linux-image-extra-3.16.0-30-generic linux-headers-3.16.0-30-generic

2. Remove old kernels, e.g.:

$ sudo apt-get purge linux-image-3.13.0-24-generic linux-image-extra-3.13.0-24-generic linux-headers-3.13.0-24 linux-headers-3.13.0-24-generic

3. Add intel linux graphics repo:

$ sudo sh -c 'echo "deb https://download.01.org/gfx/ubuntu/14.04/main trusty main #intel-linux-graphics-installer" > /etc/apt/sources.list.d/intellinuxgraphics.list'
$ wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | sudo apt-key add -
$ sudo apt-get update

4. Install driver:

$ sudo apt-get install --reinstall i915-3.16-3.13-dkms xserver-xorg-video-intel i965-va-driver intel-gpu-tools

Next step might be unnecessary if backlight change works for you:

5. Add kernel param: acpi_osi=Linux instead of: acpi_osi=Linux acpi_backlight=vendor to linux line in /boot/grub/grub.cfg via grub-customizer.

Next step might be unnecessary if backlight change works for you:

6. Create file /etc/X11/xorg.conf.d/20-intel.conf with content:

Section "Device" Identifier "card0" Driver "Intel" Option "Backlight" "intel_backlight" BusID "PCI:0:2:0" EndSection

7. Update initramfs:

$ sudo update-initramfs -u -k all

And it works after reboot.

  • I have linux kernal 4.4.0-109-generic on Ubuntu 14.04 LTS. Will you solution work? – Gaurav Agarwal Jan 22 '18 at 13:38
  • Yes, if you agree to downgrade to kernel 3.16.0-30-generic and uninstall you current one as described in step 2. – superqwerty Jan 24 '18 at 3:28

protected by Community Sep 29 '15 at 9:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.