0

My graphics card (NVIDIA GTX 750Ti) will display the BIOS, GRUB, then a black screen on launch. I know that this is a graphics card problem because the only way to see Ubuntu is by switching the monitor to the motherboard rather than the graphics card. This means I can access Ubuntu, but I can't use my graphics card, and thus can't play graphically intensive games.

0

Answered here : https://askubuntu.com/a/111298/389736

Then when you booted in, install proper driver for your GPU.

|improve this answer|||||
  • The problem is, I can access Ubuntu just by using another HDMI monitor, but the real issue is installing a NVIDIA driver and have it let me use the graphics card, and not destroy Ubuntu – bboy3577 Mar 25 '15 at 20:52
0

Which Ubuntu version? Ubuntu packages are generally recommended instead of direct from nvidia.com, so everything is coordinated and updates automatically. If you need a newer version than in standard repos, there are ppa packages available for that.

I have not tried 14.04.2 or 14.10 yet, but 64-bit 14.04.1 live/install iso, graphics seemed to work fine for my GTX 750 Ti using nomodeset boot parameter. However, once installed it would not get to gui login screen because the Maxwell chip apparently was not supported by nouveau yet. And I could not even log into text console (Ctrl+Alt_F1) which would flash motd and immediately return to login prompt.

When I installed nvidia-current from recovery boot by (enabling networking, going to root console, installing it and rebooting, that got me as far as login gui, but could not start X because that nvidia 304 version did not support my card according to logs (even though an updated 304 version in 12.04 worked for it).

So I would suggest booting to recovery mode (which I believe automatically uses nomodeset), enable networking from menu (wait for it to return to menu if any errors), then go to root console from menu. Normally you would use "sudo " prefix for these commands, but sudo is not needed from root console. If you previously installed any nvidia package (like nvidia-current) do apt-get purge nvidia* then do:

apt-get update
apt-get install nvidia-331-updates
reboot

That version worked for my GTX 750 Ti, although, I later purged that and am running nvidia-346 from xorg-edgers ppa which is no faster by default, but allows me to play with video overclocking.

If you did not use nomodeset during install, you may need to edit (e) the linux line while in grub during boot adding nomodeset to the end of it. Then edit /etc/default/grub to add nomodeset to this line like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Then run sudo update-grub

NOTE: Do not use nomodeset for hybrid Intel/Nvidia graphics on a laptop. I heard that could cause issues with hybrid graphics and everything worked fine without nomodeset when installing 14.04.1 to my laptop with Intel HD 4600/Nvidia GTX 765m graphics using nvidia-331-updates package.

|improve this answer|||||
  • Doesn't work for me unfortunately, after installing the driver the screen is still a black screen with a blinking cursor – bboy3577 Mar 25 '15 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.